summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-27 13:44:16 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-27 13:44:30 -0400
commit9ecee4409ade6e66abff41d0fb95144d06ec24f8 (patch)
tree0fbb972c1440d148d762bc872cfd5f54f5112623 /x11-libs/libXaw
parentmedia-gfx/xpaint: fix compiling in gentoo prefix (diff)
downloadgentoo-9ecee4409ade6e66abff41d0fb95144d06ec24f8.tar.gz
gentoo-9ecee4409ade6e66abff41d0fb95144d06ec24f8.tar.bz2
gentoo-9ecee4409ade6e66abff41d0fb95144d06ec24f8.zip
x11-libs/libXaw: Version bump to 1.0.14
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/Manifest1
-rw-r--r--x11-libs/libXaw/libXaw-1.0.14.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/libXaw/Manifest b/x11-libs/libXaw/Manifest
index b4481e147024..cbedebb771fe 100644
--- a/x11-libs/libXaw/Manifest
+++ b/x11-libs/libXaw/Manifest
@@ -1 +1,2 @@
DIST libXaw-1.0.13.tar.bz2 674140 BLAKE2B e141a135d1a45edfb71687951542a31d838bf560997a631b3590db0581f94768a8cc77ebd86c7cff60668e9843b1258a9eb60383a4d25b704ce9dc91fc6d0bdf SHA512 d768a39f7111802493fa1df1b80d858e4139ceeb883d45ff13ce3b7a0e775a7d2834b7ad157c8330117f04c32f38979795332dd7a119adb2344fcb1aa9cf1e2f
+DIST libXaw-1.0.14.tar.bz2 690994 BLAKE2B 9beaf5ad47b300b3bd57c85ce4c54996db824cb10377472bab8b4ec446458ce162b21e19c4e3ed8d48f10d0bddb695509e73d3274326bdd59916dfbb3c63120e SHA512 29d1c151369523ae6cb418e636b0b7b39ccccc35462a0b394dbeb46d5b6d780badd2eb872a55d9fbba1ee1af034e76c0463f40f8d8a7be2c336d08b3b1bf81d4
diff --git a/x11-libs/libXaw/libXaw-1.0.14.ebuild b/x11-libs/libXaw/libXaw-1.0.14.ebuild
new file mode 100644
index 000000000000..0bd5d0ab7b05
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}