summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-14 12:10:05 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-14 12:15:09 -0700
commitd9e158947cac307eb1425fdab94e0fde78156018 (patch)
tree9d4b4c317b1b030ca3908864db613c3abaf2a10f /x11-libs/libXfont2
parentx11-libs/libXfont2: Port to EAPI 7 (diff)
downloadgentoo-d9e158947cac307eb1425fdab94e0fde78156018.tar.gz
gentoo-d9e158947cac307eb1425fdab94e0fde78156018.tar.bz2
gentoo-d9e158947cac307eb1425fdab94e0fde78156018.zip
x11-libs/libXfont2: Version bump to 2.0.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXfont2')
-rw-r--r--x11-libs/libXfont2/Manifest1
-rw-r--r--x11-libs/libXfont2/libXfont2-2.0.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXfont2/Manifest b/x11-libs/libXfont2/Manifest
index aba9fbc949cd..911d5fdd27b5 100644
--- a/x11-libs/libXfont2/Manifest
+++ b/x11-libs/libXfont2/Manifest
@@ -1 +1,2 @@
DIST libXfont2-2.0.3.tar.bz2 497085 BLAKE2B 91780c245d5e08b45fca6e940b0fe910b43417b2bed77fa600e0b8ab2b2c5a423b8a1c680349b95592a77f5bac45b1f5a7991d05df699aad080e8c3cf4d614cf SHA512 648b664e2aa58cbc7366a1b05873aa06bd4a38060f64085783043388244af8ceced77b29a22c3ac8b6d34cd226e093bbbcc785ea1748ea65720fe7ea05b4b44b
+DIST libXfont2-2.0.4.tar.bz2 513167 BLAKE2B 924cf8462a8fc593755080866b63d6cca6e58b5d875f1d25b95271a56d883e983445f72f8950adf1964e0bf10ca5b8bb2ddfe0c56d4395086e460952a5933bd7 SHA512 7cf6c58e520e48e24fc4f05fec760fcbeaaac0cedeed57dded262c855e1515cc34cd033222945a0b016f6857b83009fc2a6946c7d632c2f7bb0060f8e8a8a106
diff --git a/x11-libs/libXfont2/libXfont2-2.0.4.ebuild b/x11-libs/libXfont2/libXfont2-2.0.4.ebuild
new file mode 100644
index 000000000000..d51778e14c3a
--- /dev/null
+++ b/x11-libs/libXfont2/libXfont2-2.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_PACKAGE_NAME=libxfont
+XORG_DOC=doc
+inherit xorg-3
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 ipv6 truetype"
+
+RDEPEND="sys-libs/zlib
+ x11-base/xorg-proto
+ x11-libs/libfontenc
+ bzip2? ( app-arch/bzip2 )
+ truetype? ( >=media-libs/freetype-2 )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc devel-docs)
+ $(use_with doc xmlto)
+ $(use_with bzip2)
+ $(use_enable truetype freetype)
+ --without-fop
+ )
+}