summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-05-09 15:39:57 -0700
committerMatt Turner <mattst88@gentoo.org>2018-05-09 15:42:04 -0700
commit24ff291d7990d3bf7c8706f37fd8eb92b919e641 (patch)
treeef55689bfab184830b61d752b6a8a81eae00bd35 /x11-libs/libdrm
parentwww-client/chromium: addpredict /dev/dri/ (diff)
downloadgentoo-24ff291d7990d3bf7c8706f37fd8eb92b919e641.tar.gz
gentoo-24ff291d7990d3bf7c8706f37fd8eb92b919e641.tar.bz2
gentoo-24ff291d7990d3bf7c8706f37fd8eb92b919e641.zip
x11-libs/libdrm: Version bump to 2.4.92
Closes: https://bugs.gentoo.org/649746
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.92.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index e1eb75c4401e..3bb2805d0af8 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -3,3 +3,4 @@ DIST libdrm-2.4.88.tar.bz2 796583 BLAKE2B 4130633fea39e12514e6c6e7a926ca7ccca618
DIST libdrm-2.4.89.tar.bz2 792940 BLAKE2B 86c8227a06060e827f39da9f1debae54784e38e34becfb3ace1329f68b0fa4cfb90532606cd3618987af2cb48b53f0277e4032055eccc164f7e6b910d3c055e0 SHA512 380e4e46cd3971a73264bd1b482791fab0503268adb65ac81b674df009662cfb8ef5741e362f19670b2a43b1c46f022d857706c9a4bebed2b1cddaa317b7706d
DIST libdrm-2.4.90.tar.bz2 822164 BLAKE2B 043428cea0f74b69577f79b3b9422546821945bb1120390d22b01a9e2a6460014eeb3902ee84241da8ba2c7683e76eb81d117a4f312ef3b8eb69647773d09710 SHA512 3d32d60c44ffdcb58667d0926e6af8d375332add1f243d8b2d37567aeef4e4b26d786294aeecf46c3dea94fc002fb73756567c457300703acfc21e32ffbd458c
DIST libdrm-2.4.91.tar.bz2 815419 BLAKE2B 7df2a4bdb4b2708cc00b71173e7e261ab7f8645a473984a7cbda2c7073f14b7f87d53eb39cc075b743e72e4cda03b2c4fca6b9df6c7d5db2c739398a13f13f35 SHA512 07578c00c121ba37033db7172590e26d1545f81c242bbce2cfb7fb904bde504822c275d6468e5c5d20360d0046ae73d9b058aa0459ba35eb11927141cc998772
+DIST libdrm-2.4.92.tar.bz2 821789 BLAKE2B 6cb2b98e43eae6a04c333693c20710e6693d218cce3ac255d935093a83e318fe5aeae3ea0a56e6ccfb615a4f917f83cdcc11bcb5fa8bc3f41c2b57a046919dcb SHA512 9b75584d8957d298125884d490b74c0a641725d17088ba47f3dc2ec9d06519d8387eb464c024ee11712b31b17fb84e1a9a52bd4ebc7c316beb7d2f8711dc9eb2
diff --git a/x11-libs/libdrm/libdrm-2.4.92.ebuild b/x11-libs/libdrm/libdrm-2.4.92.ebuild
new file mode 100644
index 000000000000..13349314bbf6
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.92.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/drm.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="elibc_FreeBSD? ( >=dev-libs/libpthread-stubs-0.4:=[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=dev-util/meson-0.43.0
+ valgrind? ( dev-util/valgrind )"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Udev is only used by tests now.
+ -Dudev=false
+ -Dcairo-tests=false
+ -Damdgpu=$(usex video_cards_amdgpu true false)
+ -Dexynos=$(usex video_cards_exynos true false)
+ -Dfreedreno=$(usex video_cards_freedreno true false)
+ -Dintel=$(usex video_cards_intel true false)
+ -Dnouveau=$(usex video_cards_nouveau true false)
+ -Domap=$(usex video_cards_omap true false)
+ -Dradeon=$(usex video_cards_radeon true false)
+ -Dtegra=$(usex video_cards_tegra true false)
+ -Dvc4=$(usex video_cards_vc4 true false)
+ -Detnaviv=$(usex video_cards_vivante true false)
+ -Dvmwgfx=$(usex video_cards_vmware true false)
+ -Dlibkms=$(usex libkms true false)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ -Dvalgrind=$(usex valgrind auto false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}