summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-05-01 11:13:53 -0700
committerMatt Turner <mattst88@gentoo.org>2017-05-01 11:14:02 -0700
commitc42055c1ad7d2da55514039dd4a68dc03a40f72a (patch)
tree45f4344b05db6982ffa1d0f35b742700b0e5a5ac /x11-libs/libdrm
parentpackage.mask: Last rite dev-python/protorpc (diff)
downloadgentoo-c42055c1ad7d2da55514039dd4a68dc03a40f72a.tar.gz
gentoo-c42055c1ad7d2da55514039dd4a68dc03a40f72a.tar.bz2
gentoo-c42055c1ad7d2da55514039dd4a68dc03a40f72a.zip
x11-libs/libdrm: Version bump to 2.4.80
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.80.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 2bc1a0c38fdb..063c383bafe4 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1,2 +1,3 @@
DIST libdrm-2.4.75.tar.bz2 774589 SHA256 2d5a500eef412cc287d12268eed79d571e262d4957a2ec9258073f305985054f SHA512 7d30029dfc384024eb6a82a04122064366572f5888ac4594fd9e02bc0a22ed2d154bef1840bd24f0543b77460d6359d7e424d424e10f4256ee3c898041be2292 WHIRLPOOL 24134409e59fe48bae02890b8153c063a49b114bcad9911487aa25ee594fe622ba04a3b2e486a2944ebe4177e205a8a970dd8d584550022780a70cb0447decf9
DIST libdrm-2.4.79.tar.bz2 783711 SHA256 c6aaf319293bce38023e9a637471b0f45c93c807d2a279060d741fc7a2e5b197 SHA512 62d6dbdf5e4e73e948fcb128a3ee76c88843d0aabf0af5751526829e9b95cff151a121af88ba9625acc7f5bc4ecfa71f9a3762005d5da76cff1d91dfc8ea8ea7 WHIRLPOOL 38e64cad8cd49a44931b598896d9ced625560a0d9da4f095d4d76eff3b64d8ab80285a6df2ff3c27ab41946fa0dcc718960cf01ac662be891c0f561997058208
+DIST libdrm-2.4.80.tar.bz2 771243 SHA256 a82a519601e9cdfad795e760807eb07ac8913b225e25fc8fe9bc03e3be6549f1 SHA512 478f64bcc6f4815368ae86d023f11ba6b37595bb9d8baa588b466c6c0e2aae48a50a489137750ed21fbabef5afabf183c78c152eb770bfe316fa7401b191a30b WHIRLPOOL 210f62c21aa27fb93eba3a8303daeab80b9da4b20ec6a70649fbad88f4277559a58018fbb12ff4b92bc6b8dc16b7ccbec1724bfcafe353382673352e9ac6d16d
diff --git a/x11-libs/libdrm/libdrm-2.4.80.ebuild b/x11-libs/libdrm/libdrm-2.4.80.ebuild
new file mode 100644
index 000000000000..464b3a444ebf
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.80.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+else
+ SRC_URI="https://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+ epatch_user
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vc4 vc4)
+ $(use_enable video_cards_vivante etnaviv-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}