summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-20 15:33:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-20 16:37:55 +0100
commite55d492db8b3d16e2b344d3a559eb3d3edce5b4f (patch)
treed2f86b65031c1d240bbd4e8c07f01e6e2076c006 /x11-libs/libfakekey
parentapp-admin/terraform: bump to version 0.12.16. (diff)
downloadgentoo-e55d492db8b3d16e2b344d3a559eb3d3edce5b4f.tar.gz
gentoo-e55d492db8b3d16e2b344d3a559eb3d3edce5b4f.tar.bz2
gentoo-e55d492db8b3d16e2b344d3a559eb3d3edce5b4f.zip
x11-libs/libfakekey: 0.3 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/libfakekey')
-rw-r--r--x11-libs/libfakekey/Manifest1
-rw-r--r--x11-libs/libfakekey/files/libfakekey-0.3-ac.patch25
-rw-r--r--x11-libs/libfakekey/libfakekey-0.3.ebuild46
3 files changed, 72 insertions, 0 deletions
diff --git a/x11-libs/libfakekey/Manifest b/x11-libs/libfakekey/Manifest
index c6aa1a5e833c..54307fe81eec 100644
--- a/x11-libs/libfakekey/Manifest
+++ b/x11-libs/libfakekey/Manifest
@@ -1 +1,2 @@
DIST libfakekey-0.1.tar.bz2 203504 BLAKE2B f3e51a1ff38dd95238a1035617045f728177c9dca96d760dfe3c4485511b500944e6f64aeb5acb3e65db3badc4c189ae25ea50f42f58a927f3ec1899c4778751 SHA512 1fda0548cf14657083a6602f8d6c08efae8cae2236de7ed17fc4058765156c6bb923956e3c7fd75f2db586399f1d8a3320ab5bbed71cc5a8b0d146590a14a808
+DIST libfakekey-0.3.tar.bz2 9672 BLAKE2B 1cd86581148e218879b14ff52fb085fd20248a475ccf00a08918d64db811b21bbba3632e799d798077a197298da4d976be3180c060a6016c396428519d1aaef2 SHA512 b0502dbb01839009de7120f8ca939c839850e7c3c88678b52d6df9f4205cbec20769cedd61c9307e8307f6bf789eee25b20d4fe20c25e7285318f5ea1334555a
diff --git a/x11-libs/libfakekey/files/libfakekey-0.3-ac.patch b/x11-libs/libfakekey/files/libfakekey-0.3-ac.patch
new file mode 100644
index 000000000000..3e0e14d79961
--- /dev/null
+++ b/x11-libs/libfakekey/files/libfakekey-0.3-ac.patch
@@ -0,0 +1,25 @@
+--- a/configure.ac 2011-05-22 14:59:45.801746472 +0100
++++ b/configure.ac 2011-05-22 15:02:59.437159981 +0100
+@@ -14,17 +14,14 @@ AC_HEADER_STDC
+
+ dnl ------ libtool versioning -----------------------------------------------
+
+-LT_CURRENT=0
+-LT_REVISION=1
+-LT_AGE=0
+-AC_SUBST(LT_CURRENT)
+-AC_SUBST(LT_REVISION)
+-AC_SUBST(LT_AGE)
++m4_define(LT_CURRENT, 0)
++m4_define(LT_REVISION, 1)
++m4_define(LT_AGE, 0)
+
+-LT_VERSION_INFO="$LT_CURRENT:$LT_REVISION:$LT_AGE"
++LT_VERSION_INFO="LT_CURRENT():LT_REVISION():LT_AGE()"
+ AC_SUBST(LT_VERSION_INFO)
+
+-LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
++LT_CURRENT_MINUS_AGE="m4_eval(LT_CURRENT() - LT_AGE())"
+ AC_SUBST(LT_CURRENT_MINUS_AGE)
+
+ dnl ------ Check for X Stuff ------------------------------------------------
diff --git a/x11-libs/libfakekey/libfakekey-0.3.ebuild b/x11-libs/libfakekey/libfakekey-0.3.ebuild
new file mode 100644
index 000000000000..4cee737959b9
--- /dev/null
+++ b/x11-libs/libfakekey/libfakekey-0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Helper library for the x11-misc/matchbox-keyboard package"
+HOMEPAGE="https://www.yoctoproject.org/tools-resources/projects/matchbox"
+SRC_URI="https://git.yoctoproject.org/cgit/cgit.cgi/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+DEPEND="x11-libs/libXtst"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-ac.patch" ) # Allow configure to use libtool-2
+
+src_prepare() {
+ default
+
+ # Fix underlinking bug #367595
+ sed -i -e 's/^fakekey_test_LDADD=/fakekey_test_LDADD=-lX11 /' \
+ tests/Makefile.am || die 'Cannot sed Makefile.am'
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # --with/without-x is ignored by configure script and X is used.
+ --with-x
+ $(use_enable debug)
+ $(use_enable doc doxygen-docs)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ default
+}