summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-05-25 23:50:21 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 23:13:04 +0200
commita6bdca64f370f8d3421d8fc5d65feb9a6d121598 (patch)
tree357765e68081b5784ca8c587da30bc25d8be194e /x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild
parentdev-libs/amdgpu-pro-opencl: bump to 19.10.785425 (diff)
downloadgentoo-a6bdca64f370f8d3421d8fc5d65feb9a6d121598.tar.gz
gentoo-a6bdca64f370f8d3421d8fc5d65feb9a6d121598.tar.bz2
gentoo-a6bdca64f370f8d3421d8fc5d65feb9a6d121598.zip
x11-libs/libfm-qt: patch issue with phantom desktop files
On some machines (slow enough?), visible desktop entries such as 'trash' would cause related temporary no longer existing files being displayed on the desktop as well. - https://github.com/lxqt/pcmanfm-qt/issues/944 - https://github.com/lxqt/libfm-qt/commit/f944be7d Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/12108 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild')
-rw-r--r--x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild b/x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild
new file mode 100644
index 000000000000..54bea0084811
--- /dev/null
+++ b/x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Qt port of libfm, a library providing components to build desktop file managers"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/5"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=lxde-base/menu-cache-1.1.0
+ media-libs/libexif:=
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+PATCHES="${FILESDIR}/${PN}-0.14.1-phantom-desktop-files.patch"