summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-27 20:26:17 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 01:28:27 +0200
commitf34c565ab42677346401b49c6c90324c1f487c5e (patch)
treeebc3dee36df7b2690ddbaa16b781622e8cbf7b4a /x11-libs/libfm-qt
parentlxqt-base/libsysstat: add version 0.4.3 (diff)
downloadgentoo-f34c565ab42677346401b49c6c90324c1f487c5e.tar.gz
gentoo-f34c565ab42677346401b49c6c90324c1f487c5e.tar.bz2
gentoo-f34c565ab42677346401b49c6c90324c1f487c5e.zip
x11-libs/libfm-qt: add version 0.15.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/libfm-qt')
-rw-r--r--x11-libs/libfm-qt/Manifest1
-rw-r--r--x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-libs/libfm-qt/Manifest b/x11-libs/libfm-qt/Manifest
index 435c2935114a..8955a00504f9 100644
--- a/x11-libs/libfm-qt/Manifest
+++ b/x11-libs/libfm-qt/Manifest
@@ -1 +1,2 @@
DIST libfm-qt-0.14.1.tar.xz 328192 BLAKE2B ff229256d3232eabc046da1fed3e4b4e51a09c3d1f2815fa726bad62f3fc53111e5d7f003e82e383dde4fe910584644e66613cbc1803ad0e11f7b6bdb2e30cfe SHA512 a265f6831a077ccb78a994828e6c69a22f2f6432b1f6ed6f404af41f013112870f7aee98067f2c466bec6cdfea040c10c7ce7e0f0ed977e5d266ec38e543d2a7
+DIST libfm-qt-0.15.1.tar.xz 337396 BLAKE2B 619787039857f0b67245ff86f4c8de1b5305909bbf1dc07f20ab53f07a955d541853066a9011bb76d04a49006732ea23c4100e94fe3c61de77f1edbbbdef5854 SHA512 9bd3f61d830e4f7ba3e72d84e3ff1a07544f6f461d6eea7ecf2b31056020e08d47d83ef920b6e1a481a470dadfb995a6b3e3b57a13574d6abca617a84c71bdf5
diff --git a/x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild b/x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild
new file mode 100644
index 000000000000..d22a9ffd9ab0
--- /dev/null
+++ b/x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Library for Building File Managers"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="BSD GPL-2+ LGPL-2.1+"
+SLOT="0/7"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=lxde-base/menu-cache-1.1.0:=
+ media-libs/libexif
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}