summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-03-10 15:46:40 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-03-10 19:03:04 -0500
commit014102ebce0ebc49bde8a5c27a4d0f954a2115be (patch)
tree0e05029f32cb3cd6466fa03364584f530b98028e /x11-libs/libvdpau
parentx11-libs/libvdpau: drop live 99999 (diff)
downloadgentoo-014102ebce0ebc49bde8a5c27a4d0f954a2115be.tar.gz
gentoo-014102ebce0ebc49bde8a5c27a4d0f954a2115be.tar.bz2
gentoo-014102ebce0ebc49bde8a5c27a4d0f954a2115be.zip
x11-libs/libvdpau: add 1.5
wrt removed -D_GNU_SOURCE, been unneeded since it started using meson given it's set as-needed by testing for secure_getenv Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-libs/libvdpau')
-rw-r--r--x11-libs/libvdpau/Manifest1
-rw-r--r--x11-libs/libvdpau/libvdpau-1.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-libs/libvdpau/Manifest b/x11-libs/libvdpau/Manifest
index 0207705af252..47e3451d26c7 100644
--- a/x11-libs/libvdpau/Manifest
+++ b/x11-libs/libvdpau/Manifest
@@ -1 +1,2 @@
DIST libvdpau-1.4.tar.bz2 139504 BLAKE2B de2b9251060f10e3126b59f44595c3b9cc65c3f5bc719133809414ed51362fb1f90fa67d0351007a178455329493f929d0983a2a7e67c29022ff351ea1f5adfc SHA512 68f502f53f4a95c9af571bd5a3f5048dd1afe30d7576f7e80751c7f29450ef8cb226c1281562b616079d6c177830ec67391d0fae33348a4627ca8c113990cd01
+DIST libvdpau-1.5.tar.gz 152838 BLAKE2B c3d76c1e46b718d71daff74232f2de9efb989c496cef7fa1016ec76d751530be39b5b6ad6354819579043f23744a647492d5d52b5ab93cae89dd82fb17d08289 SHA512 cebe0e0d9411b87238fa2adec40516881c61a67f33f80c22372f514e672e2dff839687291ab0b01d47af811c254fa65da579f360fcded3f65e382720548d3ea5
diff --git a/x11-libs/libvdpau/libvdpau-1.5.ebuild b/x11-libs/libvdpau/libvdpau-1.5.ebuild
new file mode 100644
index 000000000000..6e035344ce97
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib virtualx
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="https://gitlab.freedesktop.org/vdpau/libvdpau/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc dri"
+
+RDEPEND="
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ dri? ( x11-libs/libXext[${MULTILIB_USEDEP}] )"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )"
+
+src_prepare() {
+ default
+
+ sed -i "/^docdir/s|${PN}|${PF}|" doc/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc documentation)
+ $(meson_use dri dri2)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}