summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-28 21:49:55 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-28 22:29:18 +0200
commit3ce5241e0008fe9d2e8c11f571c3dfe85499a2d1 (patch)
tree2a04aece18ed30bec95a982a52f6cc7c5431330c /x11-libs/libwnck
parentx11-libs/pango: Version bump (diff)
downloadgentoo-3ce5241e0008fe9d2e8c11f571c3dfe85499a2d1.tar.gz
gentoo-3ce5241e0008fe9d2e8c11f571c3dfe85499a2d1.tar.bz2
gentoo-3ce5241e0008fe9d2e8c11f571c3dfe85499a2d1.zip
x11-libs/libwnck: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-libs/libwnck')
-rw-r--r--x11-libs/libwnck/Manifest1
-rw-r--r--x11-libs/libwnck/libwnck-3.20.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-libs/libwnck/Manifest b/x11-libs/libwnck/Manifest
index 17a871189915..ea05279a7d04 100644
--- a/x11-libs/libwnck/Manifest
+++ b/x11-libs/libwnck/Manifest
@@ -1,3 +1,4 @@
DIST libwnck-2.31.0.tar.xz 630792 SHA256 83f732d20781fc88b22cdc6aaf2d4f388db6d3d4ff28d1a8fd45be9fb7743a9e SHA512 54262a08882021f08f3ba7f2ddfa33fc1f02e391a0f61cf999a50a089e0d277dfe13ab133c1a46e9abf0599bd24c21dacff80b51013cbb1375d2cd71ac9abbe9 WHIRLPOOL 369c0ce1f412a0874d2f3a09e387405632726259427fff013adc4d619f4f9f80b57e376252746bdc7fe54f27749e51127ccc0870a80629cb98afb45dc420f941
DIST libwnck-3.14.0.tar.xz 675916 SHA256 f5080076346609b4c36394b879f3a86b92ced3b90a37cb54c8e9a14f00e7921c SHA512 bf5953d06697b6f623f82fe3ab3158ad3a794712bf08822fe901023e740afe4b47cc026854707b77c0c63d38614133fbef589d62385a39b99ce7e8c66c8940be WHIRLPOOL 945127110134e3b23f986fb3024b6a77577f42f9067e5760663849351687969398da0e69dca29f2e0950c8f5f364eb9e822c25d719c2f976fbf36f2e13c89d5c
DIST libwnck-3.14.1.tar.xz 683652 SHA256 bb643c9c423c8aa79c59973ce27ce91d3b180d1e9907902278fb79391f52befa SHA512 9ea05047b88e3bb47ab7d144089abbad8384a15b3d435ac250bd67ef45466f3bd264e6b4e36bb12d4acebb7da8c210ea7dae03ab5e020d7d6c1beb1658b97972 WHIRLPOOL 12a6c251f32814342f3ede40d28585c5d0afc79a51be136c0b3f30457104e3eb941ec1eafc0e53ec1acf9f4e73e633cb124ffc6d0b88edf3e8da6019ee095599
+DIST libwnck-3.20.0.tar.xz 693244 SHA256 0b2f3ffbbacc6b7baeeace4799011d4c0c938cc24187a20c1a9b32b607ea56d2 SHA512 b4e29c0c12674b64b05f47f1696752ecee14862b446d98d125709ebfff22d3bd65aead172398d82902a87110abefb1328041e217bf515369b89845577188ff7c WHIRLPOOL 8b2e0989462f61d267e7367337a5bfe0b467726a70199ed7495ac43d2d5c5e8fd5bf1af20798963d5297b6794adbe2125c656bcb489ab94ba2cc7a0cf83415c7
diff --git a/x11-libs/libwnck/libwnck-3.20.0.ebuild b/x11-libs/libwnck/libwnck-3.20.0.ebuild
new file mode 100644
index 000000000000..532df04b9cdb
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-3.20.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="https://developer.gnome.org/libwnck/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE="+introspection startup-notification tools"
+
+RDEPEND="
+ x11-libs/cairo[X]
+ >=x11-libs/gtk+-3.10:3[introspection?]
+ >=dev-libs/glib-2.32:2
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ x86-interix? ( sys-libs/itx-bind )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.6
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs
+# gnome-base/gnome-common
+
+src_configure() {
+ if use x86-interix; then
+ # activate the itx-bind package...
+ append-flags "-I${EPREFIX}/usr/include/bind"
+ append-ldflags "-L${EPREFIX}/usr/lib/bind"
+ fi
+
+ # Don't collide with SLOT=1
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable startup-notification) \
+ $(use_enable tools) \
+ --program-suffix=-${SLOT}
+}