summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-04 15:19:31 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-04 15:21:39 -0500
commit53563f5e4528f421e2d6210b6c4e91ee2c054000 (patch)
treecb8e9236108468bc2ef2a0289bcc467c4c940967 /x11-libs/libxkbcommon
parentdev-ml/cstruct: add dev-ml/cstruct (diff)
downloadgentoo-53563f5e4528f421e2d6210b6c4e91ee2c054000.tar.gz
gentoo-53563f5e4528f421e2d6210b6c4e91ee2c054000.tar.bz2
gentoo-53563f5e4528f421e2d6210b6c4e91ee2c054000.zip
x11-libs/libxkbcommon: Version bump to 1.1.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 68e582e93935..32e1920227e5 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1 +1,2 @@
DIST libxkbcommon-1.0.3.tar.xz 432944 BLAKE2B 49dcefcc17cbbfe5623728e9852e700a623e07ad7e6df78c8d7c39784948eb230f9e141d8aaa1de94305cb552244fe54d384abbc8e57f5ec5846915b5ae484e3 SHA512 b05a2db0acd6628427baad1967979a161019dec90a078a926d41f4dfeffb84eab63e627803df1a401e42c8e48953d6c434ce08d7206eae21e890890f29b03d3c
+DIST libxkbcommon-1.1.0.tar.xz 439488 BLAKE2B ddccb9942af5f5d80b750bf8f02289e073615c99bed2a8f7ff1d03ca70bffdbe3b1fe15daef2346819887efe10a308d00f671fc2ae50e0fe33e76e4b748f6d01 SHA512 6137329653ada711abc0e093532627111ab1fb53e6b2b0d05ec4d77709cfc4368f094ebbf68b23c8e9af9a69826351b64466e81c11e6593eafa7e43cd3e7bf75
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild
new file mode 100644
index 000000000000..31300e452df1
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://github.com/xkbcommon/libxkbcommon/releases/download/xkbcommon-${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson multilib-minimal ${GIT_ECLASS} python-any-r1
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="X doc static-libs test"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Denable-wayland=false # Demo applications
+ $(meson_use X enable-x11)
+ $(meson_use doc enable-docs)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}