summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-02-12 14:41:13 -0800
committerMatt Turner <mattst88@gentoo.org>2019-02-12 14:42:23 -0800
commitafbfe5d0ce8aaeeef96b7017d3b10ff9bee0b4e6 (patch)
tree5a60c7f08d1910eb012a4e0661a9d22cc2b44a5b /x11-libs/libxkbcommon
parentmedia-libs/mesa: Version bump to 19.0.0_rc3 (diff)
downloadgentoo-afbfe5d0ce8aaeeef96b7017d3b10ff9bee0b4e6.tar.gz
gentoo-afbfe5d0ce8aaeeef96b7017d3b10ff9bee0b4e6.tar.bz2
gentoo-afbfe5d0ce8aaeeef96b7017d3b10ff9bee0b4e6.zip
x11-libs/libxkbcommon: Version bump to 0.8.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index e883fd6b066c..c7b80aa58636 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1 +1,2 @@
DIST libxkbcommon-0.8.2.tar.xz 644040 BLAKE2B c323384308d9730924d6f1cb7ad55fdb3d1a37289f648b981c54dc5997c67c857d33f8ad872fc7646b462ebc97252dca30efe2a2e12d1f1f08a8a1604a5de23f SHA512 b714240ec6120bbe44b5da7a4f89b1c2f24cfd6e5ebbe81e5290d135c8f2e5a68f89ac256b73430a446167345f8db309b35dcf74f3d3840e20897cd91eccc172
+DIST libxkbcommon-0.8.3.tar.xz 646124 BLAKE2B c80d5065395ee8adec436243cf42fa82a05a5797be711b4e10d70d92ef742c707f034adf870480e1797e1b05135b5ce644e6ebefd036aaac7d3fb7435b5bd543 SHA512 0a3dfacc17eddfc10fe3edb946bede5070f2744effe642bd96076996f262a41addb691d62c0d738457da522d1fea02c297c9a2a8b1f56521adbf50ca917577c2
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild
new file mode 100644
index 000000000000..20521c37215d
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ X? (
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb]
+ )
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}