summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Hrusecky <miska@gentoo.org>2016-06-16 21:38:45 +0200
committerMichal Hrusecky <miska@gentoo.org>2016-06-16 22:04:14 +0200
commit914d64fa6bb2598db6071e7a78022b98f537654e (patch)
treeaac674d3a7a20c94931a94e722ad67b80a1a53cd /x11-libs/libyui
parentmedia-gfx/blender: bug fixes and update metadata.xml (diff)
downloadgentoo-914d64fa6bb2598db6071e7a78022b98f537654e.tar.gz
gentoo-914d64fa6bb2598db6071e7a78022b98f537654e.tar.bz2
gentoo-914d64fa6bb2598db6071e7a78022b98f537654e.zip
x11-libs/libyui: Update to the latest upstream version 3.2.5
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-libs/libyui')
-rw-r--r--x11-libs/libyui/Manifest1
-rw-r--r--x11-libs/libyui/libyui-3.2.5.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/libyui/Manifest b/x11-libs/libyui/Manifest
index 64dd43bd1736..c85a74de8f9d 100644
--- a/x11-libs/libyui/Manifest
+++ b/x11-libs/libyui/Manifest
@@ -1 +1,2 @@
DIST libyui-3.0.13.tar.gz 204028 SHA256 aa3d961f4424365efdfffd4de1facdcd870570890681ebc9e59d16ea3687e44f SHA512 b698c4d44d9fa1d888b52f8d5e2216ff4a490ef97c153fac52674a237527807140663d87ceac7b36b0c6092e9035eaec7bfe7a2e1e93922de106873130a69c66 WHIRLPOOL a7c01af68f800e1f27ce5631c0b34ea35d3f82c3d173caea1516887de9bef557662ce0e577daa6ffb2003070adac40f958c7f3dd9c64d32b46fc11d4fed72b15
+DIST libyui-3.2.5.tar.gz 218517 SHA256 0fa6bc8f226ff74c5658fea27dfea532ca1c3199bd4ed9f70b3c1bb76cca5387 SHA512 174ec6893f749bc81495c2ee620e8c7d85e9cdb61db08d4f7d800c13306eb76e0f40d20a1eafeb579344b35d99f9735b65e63525ddd804cbe30ab7f4c18bec43 WHIRLPOOL 4bd63127753f329b4e8a8d8937c80b61eecdc1d634d2985e0f97d0d5497896c853042af319721d9c86ffddfe7802f2e4ef3c41f650d30428d7c5dfd91caa8ecd
diff --git a/x11-libs/libyui/libyui-3.2.5.ebuild b/x11-libs/libyui/libyui-3.2.5.ebuild
new file mode 100644
index 000000000000..2683388c253b
--- /dev/null
+++ b/x11-libs/libyui/libyui-3.2.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="UI abstraction library"
+HOMEPAGE="https://github.com/libyui/libyui"
+SRC_URI="https://github.com/libyui/${PN}/archive/${PN}/master/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk ncurses qt4 static-libs"
+
+# Only Boost headers are needed
+DEPEND="dev-libs/boost"
+PDEPEND="
+ qt4? ( x11-libs/libyui-qt:${SLOT} )
+ ncurses? ( x11-libs/libyui-ncurses:${SLOT} )
+ gtk? ( x11-libs/libyui-gtk:${SLOT} )
+ "
+
+PATCHES=( "${FILESDIR}/${PN}-3.0.13-fix-qt-libs-check.patch" )
+
+REQUIRED_USE="|| ( gtk ncurses qt4 )"
+
+S="${WORKDIR}/${PN}-${PN}-master-${PV}"
+
+src_prepare() {
+ cp buildtools/CMakeLists.common CMakeLists.txt || die
+
+ # TODO: set proper docs deps and USE flag for building them
+ sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+ sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_WERROR=OFF
+ -DDOC_DIR="${EPREFIX}/usr/share/doc/${P}"
+ -DRESPECT_FLAGS=ON
+ $(cmake-utils_use_enable static-libs STATIC)
+ )
+ cmake-utils_src_configure
+}