summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-04-02 11:16:05 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-04-02 11:46:44 +0200
commit1c39c3f69b234cdb8eaa60dd781bbf2a51b02658 (patch)
tree46fa21fadb322986482bd04ab0a0629d88633278 /x11-libs/pango/pango-1.40.12-r1.ebuild
parentapp-eselect/eselect-audicle: Fix typo (#491382 by knasan) (diff)
downloadgentoo-1c39c3f69b234cdb8eaa60dd781bbf2a51b02658.tar.gz
gentoo-1c39c3f69b234cdb8eaa60dd781bbf2a51b02658.tar.bz2
gentoo-1c39c3f69b234cdb8eaa60dd781bbf2a51b02658.zip
x11-libs/pango: raise dependency on fontconfig
Fix breakage due to downgrading fontconfig to an older version than 2.11.91 Closes: https://bugs.gentoo.org/626466 Package-Manager: Portage-2.3.27, Repoman-2.3.9 RepoMan-Options: --force
Diffstat (limited to 'x11-libs/pango/pango-1.40.12-r1.ebuild')
-rw-r--r--x11-libs/pango/pango-1.40.12-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-libs/pango/pango-1.40.12-r1.ebuild b/x11-libs/pango/pango-1.40.12-r1.ebuild
new file mode 100644
index 000000000000..7097e5a810ec
--- /dev/null
+++ b/x11-libs/pango/pango-1.40.12-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2+ FTL"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="X +introspection test"
+
+RDEPEND="
+ >=media-libs/harfbuzz-1.2.3:=[glib(+),truetype(+),${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.11.91:1.0=[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.14-r4:=[X?,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( media-fonts/cantarell )
+ X? ( >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
+ !<=sys-devel/autoconf-2.63:2.5
+"
+
+multilib_src_configure() {
+ tc-export CXX
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --with-cairo \
+ $(multilib_native_use_enable introspection) \
+ $(use_with X xft) \
+ "$(usex X --x-includes="${EPREFIX}/usr/include" "")" \
+ "$(usex X --x-libraries="${EPREFIX}/usr/$(get_libdir)" "")"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}