summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-06 12:01:41 -0800
committerMatt Turner <mattst88@gentoo.org>2022-03-06 12:05:01 -0800
commitd02ee7dd972bf87e1f939c874249374ebb190c4a (patch)
treefac4b6183861ebfbe456dae6012fd5a796786360 /x11-libs/pango
parentapp-backup/consul-backinator: migrate to build without EGO_SUM (diff)
downloadgentoo-d02ee7dd972bf87e1f939c874249374ebb190c4a.tar.gz
gentoo-d02ee7dd972bf87e1f939c874249374ebb190c4a.tar.bz2
gentoo-d02ee7dd972bf87e1f939c874249374ebb190c4a.zip
x11-libs/pango: Version bump to 1.50.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.50.5.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index 965a243421d9..10819007eb45 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -3,3 +3,4 @@ DIST pango-1.42.4.tar.xz 833876 BLAKE2B 7de1094a29750b9e59ea1e5c92644fa5d6b83582
DIST pango-1.48.10.tar.xz 2071736 BLAKE2B 68bca7e8307fc7ddb49830c84b17e95fbb1f2e1afbe04d26d04d9bd9f48f0767b80cb7446a22150a7f3d5650614d6652d7b20be102d533b4c78adf58574c57d1 SHA512 f9acdfb3fde50e8fb4b3dfad329624754ef7cb1c6ff6d80485c1fc7a24d92095b7e9053cd8713a291fbee68cd1cd699dcdb8110265b44e97a34c5b4ef0c06390
DIST pango-1.50.3.tar.xz 4093644 BLAKE2B 7bcdde6e3fa6d2951fea017516b5f245b5b02dfaf6ab1303a6db4da8f216f948414b0cb528dca4012f046598082a6d9128d5f87c9a03a088cb393158fc0bc7f7 SHA512 6b31690ce9746b47fd8ea2f30f26c242d85cc836c812dba273a4d3e43df5484e7b3450b11de019136781dfd3dcac41f1e34189324e4700583eec1fb757763d33
DIST pango-1.50.4.tar.xz 4290504 BLAKE2B 310a7be79ebf693b3a7775fa86557539bf4ea682b0903266248ab2812504e805024b14a917531e71ad9b5637d4d3f3c1a06b84188eb01aeed37fdcc7d11679a9 SHA512 b44cf9bd7afd633fab326e70b69dcb9f00cc26dcc36361793d3654b5ae798a303d4e63e173370f396c4fa474a4118c53076927fe7cc944fc35a32adf3a656806
+DIST pango-1.50.5.tar.xz 4291708 BLAKE2B 90a1fc927ee1e06eb76ea6b82e9851e3381d5393a1992db0d3da4d3a934b5bf08f4485b40a9eef58aa906e3f0b74e71f491d947ae00310130ec5e23bde47d836 SHA512 6e898945ca9682ad113cea8a5702068d6141d39bc51a27093c6c1627c10825005155c73778cb5acab99551689dd1b47069f7d5ea102db11f00416ddcf747b8c6
diff --git a/x11-libs/pango/pango-1.50.5.ebuild b/x11-libs/pango/pango-1.50.5.ebuild
new file mode 100644
index 000000000000..13c9fd367584
--- /dev/null
+++ b/x11-libs/pango/pango-1.50.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/ https://gitlab.gnome.org/GNOME/pango"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug +introspection sysprof X"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.6.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.13.0:1.0=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ if use debug; then
+ append-cflags -DPANGO_ENABLE_DEBUG
+ else
+ append-cflags -DG_DISABLE_CAST_CHECKS
+ fi
+
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_native_use_feature introspection)
+ -Dinstall-tests=false
+ -Dfontconfig=enabled
+ $(meson_feature sysprof)
+ -Dlibthai=disabled
+ -Dcairo=enabled
+ $(meson_feature X xft)
+ -Dfreetype=enabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ insinto /usr/share/gtk-doc/html
+ # This will install PangoXft API docs regardless of USE=-X, but this is intentional
+ doins -r "${S}"/docs/Pango*
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}