summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-09 13:16:41 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-13 10:37:04 -0700
commit15997405f8f43bf97c753ffc1f259de5629345c0 (patch)
tree1c193330f941e8da96218511b3b5ce2278b883c2 /x11-libs/pixman
parentdev-python/setuptools_scm: stable 3.2.0 for hppa, bug #685518 (diff)
downloadgentoo-15997405f8f43bf97c753ffc1f259de5629345c0.tar.gz
gentoo-15997405f8f43bf97c753ffc1f259de5629345c0.tar.bz2
gentoo-15997405f8f43bf97c753ffc1f259de5629345c0.zip
x11-libs/pixman: Limit test suite $(makeopts_jobs) threads
Otherwise we would run as many OpenMP threads as there are CPU cores and ignore MAKEOPTS. Since we're running tests in parallel *and* the tests spawn multiple threads, we will still exceed $(makeopts_jobs) threads total, but I don't think that can be helped. Closes: https://bugs.gentoo.org/688926 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/pixman-0.38.4.ebuild3
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/x11-libs/pixman/pixman-0.38.4.ebuild b/x11-libs/pixman/pixman-0.38.4.ebuild
index b5fcceac9572..91bb30113a62 100644
--- a/x11-libs/pixman/pixman-0.38.4.ebuild
+++ b/x11-libs/pixman/pixman-0.38.4.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson multilib-minimal toolchain-funcs
+inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
DESCRIPTION="Low-level pixel manipulation routines"
HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -54,6 +54,7 @@ multilib_src_compile() {
}
multilib_src_test() {
+ export OMP_NUM_THREADS=$(makeopts_jobs)
meson test -v -C "${BUILD_DIR}" -t 100
}
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index 0e6923456a80..17ea41af3389 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson multilib-minimal toolchain-funcs
+inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
DESCRIPTION="Low-level pixel manipulation routines"
HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -54,6 +54,7 @@ multilib_src_compile() {
}
multilib_src_test() {
+ export OMP_NUM_THREADS=$(makeopts_jobs)
meson test -v -C "${BUILD_DIR}" -t 100
}