summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2015-10-23 11:34:57 -0700
committerMatt Turner <mattst88@gentoo.org>2015-10-23 11:35:10 -0700
commitebc150b72a7855f2396efef9001c2156bd204d9f (patch)
tree46af29bc6cfb0ca915118e9fb93b7bdcc9670220 /x11-libs/pixman
parentbitcoincore 0.11.1 & 9999: hasufell's suggestions (diff)
downloadgentoo-ebc150b72a7855f2396efef9001c2156bd204d9f.tar.gz
gentoo-ebc150b72a7855f2396efef9001c2156bd204d9f.tar.bz2
gentoo-ebc150b72a7855f2396efef9001c2156bd204d9f.zip
x11-libs/pixman: Version bump to 0.33.4.
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/Manifest1
-rw-r--r--x11-libs/pixman/pixman-0.33.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index 79fdacef40b4..88f21b73ae71 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1,3 +1,4 @@
DIST pixman-0.32.6.tar.bz2 672201 SHA256 201fc0d7d6bc0017496f2bd27b3ca14224aea0df6b624c5ee2dc0307a4ff14a4 SHA512 162e34a3ac728b348b8cd429172fa9f6ba1fc8d94716368c84a8081c42c4e2639ec7624e5528d9059695736be785ee210835c7d832b4a07a2175aec349ddffe9 WHIRLPOOL f12567cf1feb7a82956f7b2edd1db29e439933e437a9419bf505eb1ce61ce8ac9ab1fe678f0e91064ef4a776b47892930940a10c9051da165155304f3757cd92
DIST pixman-0.32.8.tar.bz2 696038 SHA256 5c63dbb3523fc4d86ed4186677815918a941b7cb390d5eec4f55cb5d66b59fb1 SHA512 43924a92f0d3e03359bd74701cc2a27c000b24fc513e0f760389da7e6ee1acec666a734003ef193d45251cc9645c07caf91142c3ff9134b1429a38a9167332a2 WHIRLPOOL 0035c6e5713a79caeeb88e865204d708f9dc2fdc8881cc4468d64f1d31243b7399f1404d76c33f43b3c17daf46f7c5e33659a961f0847993cfd3d09015fa26eb
DIST pixman-0.33.2.tar.bz2 725382 SHA256 0d12c669d69024c055ec9f877ecd6beb253796444ea3de14f8f197d438fb93fd SHA512 d74303840122160888c3983d1cb160ce29ecfbd8266f154fde69a489c7abe2c5d09c15c2414199c6e9f5458fe5dfcc166b02c7721489b493d9c5ee81bdc12b00 WHIRLPOOL 9e983b52ff26a586bec3afabf23553b7de773f3fe232ee19a217225fcc106bca93b437b7468b364a6e0cb63576a5f82a38a570b84b25feb6f490d26f6aec359d
+DIST pixman-0.33.4.tar.bz2 722970 SHA256 f3fc9a2aadf40196af1c3a8ee5a94f18e4fcbaa5741e23fbf0351772b9c92e09 SHA512 db7d1bea08e61e6f70091ed484c963ca00bf4746f5b09a2e58fe60dd1b85045c0aaa69e831bd77c60e81af8e0c29518c4bdad7f13c6a57e59d246e7908aeed82 WHIRLPOOL d073dfe87dc8871470a0148d341f47b5b943621fdb63beb94456a24a9b15af7ffa78f15e0a86cb07a0b042161757cf1c724d5ac27a059376075b80ad6b4c5362
diff --git a/x11-libs/pixman/pixman-0.33.4.ebuild b/x11-libs/pixman/pixman-0.33.4.ebuild
new file mode 100644
index 000000000000..dc3517f48dae
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.33.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+if [[ $PV = 9999* ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+IUSE="altivec iwmmxt loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20131008
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable cpu_flags_x86_mmxext mmx)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable cpu_flags_x86_ssse3 ssse3)
+ $(use_enable altivec vmx)
+ $(use_enable neon arm-neon)
+ $(use_enable iwmmxt arm-iwmmxt)
+ $(use_enable loongson2f loongson-mmi)
+ --disable-gtk
+ --disable-libpng
+ )
+ xorg-2_src_configure
+}