summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/qscintilla
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/Manifest2
-rw-r--r--x11-libs/qscintilla/metadata.xml17
-rw-r--r--x11-libs/qscintilla/qscintilla-2.8.4-r1.ebuild91
-rw-r--r--x11-libs/qscintilla/qscintilla-2.9.ebuild91
4 files changed, 201 insertions, 0 deletions
diff --git a/x11-libs/qscintilla/Manifest b/x11-libs/qscintilla/Manifest
new file mode 100644
index 000000000000..682d80e12cea
--- /dev/null
+++ b/x11-libs/qscintilla/Manifest
@@ -0,0 +1,2 @@
+DIST QScintilla-gpl-2.8.4.tar.gz 3031919 SHA256 9b7b2d7440cc39736bbe937b853506b3bd218af3b79095d4f710cccb0fabe80f SHA512 ab10dc756231b293ddebc06e681bb65a11b2be2a4c4132a5b2a27ca583adef76af325fa95748888d9091f2e89a30494d370df262c4eaba7b7fbed04fb7c76907 WHIRLPOOL 7357addbc0ad8869c5749a67106c18e47d79e32399416cc2867461fa8ad0c662711b8937987cb7c3cd5b83fe9f88e1529911eefec28a972e86c7f242c8c0d634
+DIST QScintilla-gpl-2.9.tar.gz 2435116 SHA256 d7c32e32582f93779de861006d87467b38b9ebc06e3d0b32e981cb24369fa417 SHA512 a74b7b1182e9f602aa9f61072877d8dba93c430453ed70e18d74013dbda8b0faef30629f2c086d3b06d0632b3f4980570362bb6e635c15686be1be47eaeecb00 WHIRLPOOL b27a3ff2b48dbbf034deb4fdf09259815dcee63bfffe29651cf1e5e9ceeedb408ebc0bae440479a8206af7046f80143c291c10a0293942b64eb61c5e02549ed4
diff --git a/x11-libs/qscintilla/metadata.xml b/x11-libs/qscintilla/metadata.xml
new file mode 100644
index 000000000000..661ed4fe6647
--- /dev/null
+++ b/x11-libs/qscintilla/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>python</herd>
+ <use>
+ <flag name="designer">Build plugin for Qt Designer</flag>
+ </use>
+ <upstream>
+ <maintainer status="active">
+ <email>phil@riverbankcomputing.com</email>
+ <name>Phil Thompson</name>
+ </maintainer>
+ <bugs-to>mailto:qscintilla@riverbankcomputing.com</bugs-to>
+ <remote-id type="sourceforge">pyqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-libs/qscintilla/qscintilla-2.8.4-r1.ebuild b/x11-libs/qscintilla/qscintilla-2.8.4-r1.ebuild
new file mode 100644
index 000000000000..9c5ece9fd7af
--- /dev/null
+++ b/x11-libs/qscintilla/qscintilla-2.8.4-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic qmake-utils
+
+MY_P=QScintilla-gpl-${PV}
+
+DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
+HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0/11"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="designer doc"
+
+DEPEND="
+ >=dev-qt/qtcore-4.8.5:4
+ >=dev-qt/qtgui-4.8.5:4
+ designer? ( >=dev-qt/designer-4.8.5:4 )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ default
+
+ # Sub-slot sanity check
+ local subslot=${SLOT#*/}
+ local version=$(sed -nre 's:.*VERSION\s*=\s*([0-9\.]+):\1:p' "${S}"/Qt4Qt5/qscintilla.pro)
+ local major=${version%%.*}
+ if [[ ${subslot} != ${major} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${subslot}) does not match QScintilla major version (${major})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${major}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+}
+
+src_configure() {
+ pushd Qt4Qt5 > /dev/null
+ eqmake4
+ popd > /dev/null
+
+ if use designer; then
+ # prevent building against system version (bug 466120)
+ append-cxxflags -I../Qt4Qt5
+ append-ldflags -L../Qt4Qt5
+
+ pushd designer-Qt4Qt5 > /dev/null
+ eqmake4
+ popd > /dev/null
+ fi
+}
+
+src_compile() {
+ pushd Qt4Qt5 > /dev/null
+ emake
+ popd > /dev/null
+
+ if use designer; then
+ pushd designer-Qt4Qt5 > /dev/null
+ emake
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ pushd Qt4Qt5 > /dev/null
+ emake INSTALL_ROOT="${D}" install
+ popd > /dev/null
+
+ if use designer; then
+ pushd designer-Qt4Qt5 > /dev/null
+ emake INSTALL_ROOT="${D}" install
+ popd > /dev/null
+ fi
+
+ dodoc NEWS
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/html-Qt4Qt5/*
+ fi
+}
diff --git a/x11-libs/qscintilla/qscintilla-2.9.ebuild b/x11-libs/qscintilla/qscintilla-2.9.ebuild
new file mode 100644
index 000000000000..99f80015ba9b
--- /dev/null
+++ b/x11-libs/qscintilla/qscintilla-2.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic qmake-utils
+
+MY_P=QScintilla-gpl-${PV}
+
+DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
+HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="designer doc"
+
+DEPEND="
+ >=dev-qt/qtcore-4.8.5:4
+ >=dev-qt/qtgui-4.8.5:4
+ designer? ( >=dev-qt/designer-4.8.5:4 )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ default
+
+ # Sub-slot sanity check
+ local subslot=${SLOT#*/}
+ local version=$(sed -nre 's:.*VERSION\s*=\s*([0-9\.]+):\1:p' "${S}"/Qt4Qt5/qscintilla.pro)
+ local major=${version%%.*}
+ if [[ ${subslot} != ${major} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${subslot}) does not match QScintilla major version (${major})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${major}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+}
+
+src_configure() {
+ pushd Qt4Qt5 > /dev/null
+ eqmake4
+ popd > /dev/null
+
+ if use designer; then
+ # prevent building against system version (bug 466120)
+ append-cxxflags -I../Qt4Qt5
+ append-ldflags -L../Qt4Qt5
+
+ pushd designer-Qt4Qt5 > /dev/null
+ eqmake4
+ popd > /dev/null
+ fi
+}
+
+src_compile() {
+ pushd Qt4Qt5 > /dev/null
+ emake
+ popd > /dev/null
+
+ if use designer; then
+ pushd designer-Qt4Qt5 > /dev/null
+ emake
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ pushd Qt4Qt5 > /dev/null
+ emake INSTALL_ROOT="${D}" install
+ popd > /dev/null
+
+ if use designer; then
+ pushd designer-Qt4Qt5 > /dev/null
+ emake INSTALL_ROOT="${D}" install
+ popd > /dev/null
+ fi
+
+ dodoc NEWS
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/html-Qt4Qt5/*
+ fi
+}