summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-23 13:44:06 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-23 14:47:38 +0200
commit59a02bdf5a7288bebad96c64b4db94d8a56dd4f4 (patch)
tree9fa6b8946e92647a611182a9e22cec2765705097 /x11-libs/qwtplot3d
parentx11-libs/qwt: add 5.2.3 (diff)
downloadgentoo-59a02bdf5a7288bebad96c64b4db94d8a56dd4f4.tar.gz
gentoo-59a02bdf5a7288bebad96c64b4db94d8a56dd4f4.tar.bz2
gentoo-59a02bdf5a7288bebad96c64b4db94d8a56dd4f4.zip
x11-libs/qwtplot3d: import from ::sci
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'x11-libs/qwtplot3d')
-rw-r--r--x11-libs/qwtplot3d/Manifest1
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch28
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-examples.patch125
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch12
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-qt-4.8.0.patch34
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch31
-rw-r--r--x11-libs/qwtplot3d/metadata.xml17
-rw-r--r--x11-libs/qwtplot3d/qwtplot3d-0.2.ebuild65
8 files changed, 313 insertions, 0 deletions
diff --git a/x11-libs/qwtplot3d/Manifest b/x11-libs/qwtplot3d/Manifest
new file mode 100644
index 000000000000..d4cc3220a601
--- /dev/null
+++ b/x11-libs/qwtplot3d/Manifest
@@ -0,0 +1 @@
+DIST qwtplot3d-0.2.tar.gz 322366 BLAKE2B 7c589efe13409089dd6e1b579f19891fb0b75e44a4add87128822b3184c4d22ec0e7b04ce4c7c52dfaf8644a17a8506419726ae1ab50ab7cd7bc9ea9f84f9268 SHA512 92addf10865d090216a92d5ced5b0793b50657c6c5e5faf5c8f78120cc9c94a0b6f8e351d2e053b73951411b8f81a4179c0f17aea27d78cd748df8f81b31bcf9
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch b/x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch
new file mode 100644
index 000000000000..b0632a380a2a
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch
@@ -0,0 +1,28 @@
+--- qwtplot3d/doc/Doxyfile.doxygen.orig 2007-11-26 22:30:57.000000000 +0000
++++ qwtplot3d/doc/Doxyfile.doxygen 2007-11-26 22:30:03.000000000 +0000
+@@ -116,7 +116,7 @@
+ HTML_ALIGN_MEMBERS = YES
+ GENERATE_HTMLHELP = NO
+ CHM_FILE = qwtplot3d.chm
+-HHC_LOCATION = "c:\Programme\HTML Help Workshop\hhc.exe"
++#HHC_LOCATION = "c:\Programme\HTML Help Workshop\hhc.exe"
+ GENERATE_CHI = NO
+ BINARY_TOC = YES
+ TOC_EXPAND = YES
+@@ -181,7 +181,7 @@
+ MACRO_EXPANSION = NO
+ EXPAND_ONLY_PREDEF = NO
+ SEARCH_INCLUDES = YES
+-INCLUDE_PATH = V:/cvs/qwtplot3d/include/
++INCLUDE_PATH = ../include
+ INCLUDE_FILE_PATTERNS = *.h
+ PREDEFINED = QWT3D_NOT_FOR_DOXYGEN \
+ QT_VERSION=0x040000
+@@ -212,7 +212,6 @@
+ GRAPHICAL_HIERARCHY = YES
+ DIRECTORY_GRAPH = YES
+ DOT_IMAGE_FORMAT = png
+-DOT_PATH = V:/graphviz/Graphviz/bin/
+ DOTFILE_DIRS =
+ MAX_DOT_GRAPH_WIDTH = 974
+ MAX_DOT_GRAPH_HEIGHT = 10000
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-examples.patch b/x11-libs/qwtplot3d/files/qwtplot3d-examples.patch
new file mode 100644
index 000000000000..f142c3379274
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-examples.patch
@@ -0,0 +1,125 @@
+diff -Nur qwtplot3d.orig/examples/axes/src/axesmainwindow.cpp qwtplot3d/examples/axes/src/axesmainwindow.cpp
+--- qwtplot3d.orig/examples/axes/src/axesmainwindow.cpp 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/axes/src/axesmainwindow.cpp 2007-11-26 22:21:56.000000000 +0000
+@@ -9,7 +9,7 @@
+
+ #include "axes.h"
+ #include "axesmainwindow.h"
+-#include "../../../include/qwt3d_function.h"
++#include <qwt3d_function.h>
+
+ using namespace std;
+ using namespace Qwt3D;
+diff -Nur qwtplot3d.orig/examples/common.pro qwtplot3d/examples/common.pro
+--- qwtplot3d.orig/examples/common.pro 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/common.pro 2007-11-26 23:43:33.000000000 +0000
+@@ -1,13 +1,13 @@
+ TEMPLATE = app
+-CONFIG += qt warn_on thread debug
++CONFIG += qt warn_on thread
+ UI_DIR = tmp
+ MOC_DIR = tmp
+ OBJECTS_DIR = tmp
+-INCLUDEPATH += ../../include
++INCLUDEPATH += /usr/include/qwtplot3d
+ DEPENDPATH = $$INCLUDEPATH
+ DESTDIR = ../bin
+
+-unix:LIBS += -lqwtplot3d -L../../lib
++unix:LIBS += -lqwtplot3d
+ linux-g++:QMAKE_CXXFLAGS += -fno-exceptions
+
+ win32{
+@@ -25,7 +25,7 @@
+ ISQT4 = $$find(MYVERSION, ^[2-9])
+
+ !isEmpty( ISQT4 ) {
+-RESOURCES = ../images.qrc
++#RESOURCES = ../images.qrc
+ QT += opengl
+ }
+
+diff -Nur qwtplot3d.orig/examples/enrichments/src/enrichmentmainwindow.cpp qwtplot3d/examples/enrichments/src/enrichmentmainwindow.cpp
+--- qwtplot3d.orig/examples/enrichments/src/enrichmentmainwindow.cpp 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/enrichments/src/enrichmentmainwindow.cpp 2007-11-26 22:22:48.000000000 +0000
+@@ -6,7 +6,7 @@
+
+ #include "enrichmentmainwindow.h"
+ #include "enrichments.h"
+-#include "../../../include/qwt3d_function.h"
++#include <qwt3d_function.h>
+
+ using namespace Qwt3D;
+
+diff -Nur qwtplot3d.orig/examples/mesh2/src/colormapreader.h qwtplot3d/examples/mesh2/src/colormapreader.h
+--- qwtplot3d.orig/examples/mesh2/src/colormapreader.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/colormapreader.h 2007-11-26 22:23:19.000000000 +0000
+@@ -5,7 +5,7 @@
+ #include <qframe.h>
+ #include <qpixmap.h>
+
+-#include "../../../include/qwt3d_types.h"
++#include <qwt3d_types.h>
+
+ #if QT_VERSION < 0x040000
+
+diff -Nur qwtplot3d.orig/examples/mesh2/src/functions.h qwtplot3d/examples/mesh2/src/functions.h
+--- qwtplot3d.orig/examples/mesh2/src/functions.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/functions.h 2007-11-26 22:23:47.000000000 +0000
+@@ -2,8 +2,8 @@
+ #define __EXAMPLE_H__
+
+ #include <math.h>
+-#include "../../../include/qwt3d_parametricsurface.h"
+-#include "../../../include/qwt3d_function.h"
++#include <qwt3d_parametricsurface.h>
++#include <qwt3d_function.h>
+
+ using namespace Qwt3D;
+
+diff -Nur qwtplot3d.orig/examples/mesh2/src/lightingdlg.h qwtplot3d/examples/mesh2/src/lightingdlg.h
+--- qwtplot3d.orig/examples/mesh2/src/lightingdlg.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/lightingdlg.h 2007-11-26 22:24:41.000000000 +0000
+@@ -3,10 +3,10 @@
+
+ #include <math.h>
+ #include <qapplication.h>
+-#include "../../../include/qwt3d_parametricsurface.h"
+-#include "../../../include/qwt3d_surfaceplot.h"
+-#include "../../../include/qwt3d_enrichment.h"
+-#include "../../../include/qwt3d_color.h"
++#include <qwt3d_parametricsurface.h>
++#include <qwt3d_surfaceplot.h>
++#include <qwt3d_enrichment.h>
++#include <qwt3d_color.h>
+
+ #if QT_VERSION < 0x040000
+ #include "lightingdlgbase.h"
+diff -Nur qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.cpp qwtplot3d/examples/mesh2/src/mesh2mainwindow.cpp
+--- qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.cpp 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/mesh2mainwindow.cpp 2007-11-26 22:25:33.000000000 +0000
+@@ -33,9 +33,9 @@
+ #include "colormapreader.h"
+ #include "lightingdlg.h"
+ #include "femreader.h"
+-#include "../../../include/qwt3d_io.h"
+-#include "../../../include/qwt3d_io_gl2ps.h"
+-#include "../../../include/qwt3d_io_reader.h"
++#include <qwt3d_io.h>
++#include <qwt3d_io_gl2ps.h>
++#include <qwt3d_io_reader.h>
+
+ using namespace Qwt3D;
+ using namespace std;
+diff -Nur qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.h qwtplot3d/examples/mesh2/src/mesh2mainwindow.h
+--- qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/mesh2mainwindow.h 2007-11-26 22:26:09.000000000 +0000
+@@ -1,7 +1,7 @@
+ #ifndef mesh2mainwindow_h__2004_03_07_13_38_begin_guarded_code
+ #define mesh2mainwindow_h__2004_03_07_13_38_begin_guarded_code
+
+-#include "../../../include/qwt3d_surfaceplot.h"
++#include <qwt3d_surfaceplot.h>
+
+
+ #if QT_VERSION < 0x040000
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch b/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch
new file mode 100644
index 000000000000..a76fe831ab91
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur qwtplot3d-orig/include/qwt3d_function.h qwtplot3d/include/qwt3d_function.h
+--- qwtplot3d-orig/include/qwt3d_function.h 2009-07-25 18:18:58.000000000 -0400
++++ qwtplot3d/include/qwt3d_function.h 2009-07-25 18:19:19.000000000 -0400
+@@ -2,6 +2,7 @@
+ #define qwt3d_function_h__2004_03_05_13_51_begin_guarded_code
+
+ #include "qwt3d_gridmapping.h"
++#include <cstdio>
+
+ namespace Qwt3D
+ {
+Only in qwtplot3d/tmp: qwt3d_function.o
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-qt-4.8.0.patch b/x11-libs/qwtplot3d/files/qwtplot3d-qt-4.8.0.patch
new file mode 100644
index 000000000000..ae10f48f0707
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-qt-4.8.0.patch
@@ -0,0 +1,34 @@
+diff -urbN qwtplot3d/include/qwt3d_io_gl2ps.h qwtplot3d.patched/include/qwt3d_io_gl2ps.h
+--- qwtplot3d/include/qwt3d_io_gl2ps.h 2005-07-10 16:54:52.000000000 +0300
++++ qwtplot3d.patched/include/qwt3d_io_gl2ps.h 2012-01-21 22:15:20.000000000 +0200
+@@ -2,12 +2,7 @@
+ #define qwt3d_io_gl2ps_h__2004_05_07_01_16_begin_guarded_code
+
+ #include <time.h>
+-
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL>
+
+ #include "qwt3d_types.h"
+ #include "qwt3d_io.h"
+diff -urbN qwtplot3d/include/qwt3d_openglhelper.h qwtplot3d.patched/include/qwt3d_openglhelper.h
+--- qwtplot3d/include/qwt3d_openglhelper.h 2005-07-19 17:40:28.000000000 +0300
++++ qwtplot3d.patched/include/qwt3d_openglhelper.h 2012-01-21 22:29:56.000000000 +0200
+@@ -2,11 +2,8 @@
+ #define __openglhelper_2003_06_06_15_49__
+
+ #include "qglobal.h"
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL>
++#include <GL/glu.h>
+
+ namespace Qwt3D
+ {
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch b/x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch
new file mode 100644
index 000000000000..ee6534a5cfdb
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch
@@ -0,0 +1,31 @@
+--- a/qwtplot3d.pro 2009-04-07 19:45:29.985645378 +0100
++++ b/qwtplot3d.pro 2009-04-07 19:46:50.095747068 +0100
+@@ -80,13 +80,11 @@
+ include/qwt3d_graphplot.h \
+ include/qwt3d_multiplot.h
+
+-# gl2ps support
+-HEADERS+=3rdparty/gl2ps/gl2ps.h \
+- include/qwt3d_io_gl2ps.h
++# gl2ps support taken from system libs
++HEADERS+=include/qwt3d_io_gl2ps.h
+
+-SOURCES+=src/qwt3d_io_gl2ps.cpp \
+- 3rdparty/gl2ps/gl2ps.c
+-
++SOURCES+=src/qwt3d_io_gl2ps.cpp
++unix:LIBS += -lgl2ps
+ # zlib support for gl2ps
+ zlib {
+ DEFINES += GL2PS_HAVE_ZLIB
+--- a/src/qwt3d_io_gl2ps.cpp 2009-04-07 19:44:38.536418391 +0100
++++ b/src/qwt3d_io_gl2ps.cpp 2009-04-07 19:45:03.685133854 +0100
+@@ -4,7 +4,7 @@
+
+ #include <time.h>
+ #include "qwt3d_openglhelper.h"
+-#include "../3rdparty/gl2ps/gl2ps.h"
++#include <gl2ps.h>
+ #include "qwt3d_io_gl2ps.h"
+ #include "qwt3d_plot.h"
+
diff --git a/x11-libs/qwtplot3d/metadata.xml b/x11-libs/qwtplot3d/metadata.xml
new file mode 100644
index 000000000000..03ad3bea5fc5
--- /dev/null
+++ b/x11-libs/qwtplot3d/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ QwtPlot3D is a graphics extension to the Qt GUI application framework.
+ It provides a 3D plotting widget for scientific data and mathematical expressions.
+ It compares to the existing Qwt Project.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">qwtplot3d</remote-id>
+ <remote-id type="github">SciDAVis/qwtplot3d</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-libs/qwtplot3d/qwtplot3d-0.2.ebuild b/x11-libs/qwtplot3d/qwtplot3d-0.2.ebuild
new file mode 100644
index 000000000000..affe2541eb62
--- /dev/null
+++ b/x11-libs/qwtplot3d/qwtplot3d-0.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc"
+DOCS_CONFIG_NAME="Doxyfile.doxygen"
+
+inherit docs qmake-utils
+
+DESCRIPTION="3D plotting library for Qt5"
+HOMEPAGE="http://qwtplot3d.sourceforge.net/ https://github.com/SciDAVis/qwtplot3d/"
+SRC_URI="https://github.com/SciDAVis/qwtplot3d/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="doc examples"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ x11-libs/gl2ps
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-examples.patch"
+ "${FILESDIR}/${PN}-doxygen.patch"
+ "${FILESDIR}/${PN}-gcc44.patch"
+ "${FILESDIR}/${PN}-qt-4.8.0.patch"
+ "${FILESDIR}/${PN}-sys-gl2ps.patch"
+)
+
+src_prepare() {
+ default
+ cat >> ${PN}.pro <<-EOF
+ target.path = "${EPREFIX}/usr/$(get_libdir)"
+ headers.path = "${EPREFIX}/usr/include/${PN}"
+ headers.files = \$\$HEADERS
+ INSTALLS = target headers
+ EOF
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install () {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}