summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-25 16:33:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-25 17:01:45 +0100
commit71d6d1edfc98b69a916663e6a8ded466da1b313f (patch)
treec4809804ab5f9c55db9e4320faab67005cf3e470 /x11-libs/tslib/tslib-1.21.ebuild
parentsys-libs/darwin-libc-headers: revbump to add missing Frameworks and headers (diff)
downloadgentoo-71d6d1edfc98b69a916663e6a8ded466da1b313f.tar.gz
gentoo-71d6d1edfc98b69a916663e6a8ded466da1b313f.tar.bz2
gentoo-71d6d1edfc98b69a916663e6a8ded466da1b313f.zip
x11-libs/tslib: 1.21 version bump
Closes: https://bugs.gentoo.org/618654 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/tslib/tslib-1.21.ebuild')
-rw-r--r--x11-libs/tslib/tslib-1.21.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-libs/tslib/tslib-1.21.ebuild b/x11-libs/tslib/tslib-1.21.ebuild
new file mode 100644
index 000000000000..ac72cb85bb3f
--- /dev/null
+++ b/x11-libs/tslib/tslib-1.21.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Touchscreen Access Library"
+HOMEPAGE="https://github.com/kergoth/tslib"
+SRC_URI="https://github.com/libts/tslib/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2 uinput? ( GPL-2+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="evdev sdl uinput"
+
+BDEPEND="
+ evdev? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ evdev? ( dev-libs/libevdev[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS NEWS README{,.md} )
+
+PATCHES=( "${FILESDIR}/${P}-optional-utils.patch" )
+
+src_configure() {
+ my_configure() {
+ local mycmakeargs=(
+ -Denable-input-evdev=$(usex evdev)
+ -DENABLE_TOOLS=$(usex uinput $(multilib_is_native_abi && echo ON || echo OFF) OFF)
+ -DENABLE_UTILS=$(multilib_is_native_abi && echo ON || echo OFF)
+ -Denable-arctic2=ON
+ -Denable-collie=ON
+ -Denable-corgi=ON
+ -Denable-cy8mrln-palmpre=ON
+ -Denable-dejitter=ON
+ -Denable-dmc=ON
+ -Denable-dmc_dus3000=ON
+ -Denable-galax=ON
+ -Denable-h3600=ON
+ -Denable-input=ON
+ -Denable-linear-h2200=ON
+ -Denable-linear=ON
+ -Denable-mk712=ON
+ -Denable-one-wire-ts-input=ON
+ -Denable-pthres=ON
+ -Denable-tatung=ON
+ -Denable-ucb1x00=ON
+ -Denable-variance=ON
+ )
+ multilib_is_native_abi && mycmakeargs+=( -Dwith-sdl=$(usex sdl) )
+
+ cmake-utils_src_configure
+ }
+ multilib_parallel_foreach_abi my_configure
+}