summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2017-11-26 15:57:32 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2017-11-26 16:10:56 +0100
commit40f716c732fb1b0b3ac7323e896fdd9a9d768b5f (patch)
treef147fa7ffaad02a8c65a3d1cf9c828133b304bc0 /x11-libs/xapps
parentx11-wm/muffin: Version bump 3.6.0 (diff)
downloadgentoo-40f716c732fb1b0b3ac7323e896fdd9a9d768b5f.tar.gz
gentoo-40f716c732fb1b0b3ac7323e896fdd9a9d768b5f.tar.bz2
gentoo-40f716c732fb1b0b3ac7323e896fdd9a9d768b5f.zip
x11-libs/xapps: Version bump 1.0.4
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'x11-libs/xapps')
-rw-r--r--x11-libs/xapps/Manifest1
-rw-r--r--x11-libs/xapps/xapps-1.0.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/xapps/Manifest b/x11-libs/xapps/Manifest
index ace91cf8306f..d607702329a0 100644
--- a/x11-libs/xapps/Manifest
+++ b/x11-libs/xapps/Manifest
@@ -1,2 +1,3 @@
DIST xapps-1.0.2.tar.gz 109067 SHA256 1443e9f319763f8b90749ea9669880005f315af060f7bbaa2b4241b4c4ca49a4 SHA512 59426a8e39af48eb6435cb649fd88601a1a324d284ed9d222f12b7e52e70a0b250235b5924af1ecb7d6f3abd6c8e53e0cf38672c94dff44193f01dbc90c35646 WHIRLPOOL 6e4f01f17c7450b246dbfbed3fa229315166f5223c051422be7fd8510df376d6e916ab5e9eaac645abd57e055ac89da81291aa73de38af6a9129497f1994201d
DIST xapps-1.0.3.tar.gz 121490 SHA256 bb1b89b586eec67fc109140de791710c5b4ec488b01ef3ac261e288a27b4797e SHA512 1182062153fc7344f94e9a25e98a457237b54c4841e425d202f8b57751f288e460423ca7408a888aff7a2b162acd194efda332b6acbd0a5cc2c12ae9414ea3c3 WHIRLPOOL 43784ca1328d810f38a3843eb0ef9bc9ac9a30c4bbc524c4898e0f7f3c0e6bbe3ceb507be4d48e962f06be8a652ffbc4a80ac3ed76d0807cce80d1d86f87c211
+DIST xapps-1.0.4.tar.gz 129497 BLAKE2B d668ff840fa83b4a037c4b0f1c502e1851236d7998c4e5c7161a779e170eee6f6f47a2a17e71f332edf3f42f6ccb88c20379ad3b12847277f5e57a3b3765f2ef SHA512 1b735167f8edf15be1093255691c67ee1ae99664a714b75d46b1b782b00a6d1da72befc484ee66f070a829b6b8fd4dfa50bec5033220f66a1a4b577363b673b7
diff --git a/x11-libs/xapps/xapps-1.0.4.ebuild b/x11-libs/xapps/xapps-1.0.4.ebuild
new file mode 100644
index 000000000000..c72b5f1df5d4
--- /dev/null
+++ b/x11-libs/xapps/xapps-1.0.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils xdg-utils
+
+DESCRIPTION="Cross-desktop libraries and common resources"
+HOMEPAGE="https://github.com/linuxmint/xapps/"
+LICENSE="GPL-3"
+
+SRC_URI="https://github.com/linuxmint/xapps/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+IUSE="introspection static-libs"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ dev-libs/gobject-introspection:0=
+ gnome-base/libgnomekbd
+ gnome-base/gnome-common
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22.0:2[introspection?]
+ >=x11-libs/gtk+-3.3.16:3[introspection?]
+ x11-libs/libxkbfile
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+"
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-gtk-doc \
+ --enable-gtk-doc-html \
+ $(use_enable introspection) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ rm -rf "${ED%/}"/usr/bin || die
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}