summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-06-17 08:24:12 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-06-17 08:24:12 -0500
commit1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73 (patch)
treed1d6a88f592437a34990712e7a0e9b73002eb3cd /x11-libs/xcb-util-xrm
parentdev-libs/libsodium: Add IUSE="cpu_flags_x86_sse4_1 cpu_flags_x86_aes" (diff)
downloadgentoo-1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73.tar.gz
gentoo-1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73.tar.bz2
gentoo-1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73.zip
x11-libs/xcb-util-xrm: Initial import, fixes #579650
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-libs/xcb-util-xrm')
-rw-r--r--x11-libs/xcb-util-xrm/Manifest1
-rw-r--r--x11-libs/xcb-util-xrm/metadata.xml23
-rw-r--r--x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild26
3 files changed, 50 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-xrm/Manifest b/x11-libs/xcb-util-xrm/Manifest
new file mode 100644
index 000000000000..38e8ea590934
--- /dev/null
+++ b/x11-libs/xcb-util-xrm/Manifest
@@ -0,0 +1 @@
+DIST xcb-util-xrm-1.0.tar.bz2 327196 SHA256 9400ac1ecefdb469b2f6ef6bf0460643b6c252fb8406e91377b89dd12eefbbc0 SHA512 b49d97b018a231b5642bb05a287eb7720d9e1ffe15024d46a4c7ebf2f9cc37a0a4a3262d9aa963fe9554ca801ba013ad6cb5d3f87b67daf4d69efd180d7ba8fd WHIRLPOOL d6ed2eb13730f01813792bbe2a165dcc9dc228681c7e6fb9494c8f500bd2f9f4ce20b47b1ce63cd2a5eed8853385d6667664685fcf87813d1ae5c2d4d4a3e973
diff --git a/x11-libs/xcb-util-xrm/metadata.xml b/x11-libs/xcb-util-xrm/metadata.xml
new file mode 100644
index 000000000000..2fa61d7ee9d1
--- /dev/null
+++ b/x11-libs/xcb-util-xrm/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ The XCB util modules provides a number of libraries which sit on top
+ of libxcb, the core X protocol library, and some of the extension
+ libraries. These experimental libraries provide convenience functions
+ and interfaces which make the raw X protocol more usable. Some of the
+ libraries also provide client-side code which is not strictly part of
+ the X protocol but which have traditionally been provided by Xlib.
+ </longdescription>
+ <maintainer type="person">
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Airblader/xcb-util-xrm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild
new file mode 100644
index 000000000000..f141ce6ff082
--- /dev/null
+++ b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_BASE_INDIVIDUAL_URI=""
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+SRC_URI="https://github.com/Airblader/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( x11-libs/libX11[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ xorg-2_src_configure
+}