summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-04 11:53:27 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-04 11:55:06 -0700
commit0470ea8a4ad56ed9bad4e424c3bc844d14e9dfb0 (patch)
tree414e4c1723e22bc54ab56f3d127280c187a47229 /x11-libs
parentdev-lang/python: ignore EACCES instead of EPERM (diff)
downloadgentoo-0470ea8a4ad56ed9bad4e424c3bc844d14e9dfb0.tar.gz
gentoo-0470ea8a4ad56ed9bad4e424c3bc844d14e9dfb0.tar.bz2
gentoo-0470ea8a4ad56ed9bad4e424c3bc844d14e9dfb0.zip
x11-libs/libdrm: EAPI=7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libdrm/libdrm-9999.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/x11-libs/libdrm/libdrm-9999.ebuild b/x11-libs/libdrm/libdrm-9999.ebuild
index 686210699256..46ea35c8a426 100644
--- a/x11-libs/libdrm/libdrm-9999.ebuild
+++ b/x11-libs/libdrm/libdrm-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/drm.git"
@@ -16,7 +16,7 @@ HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
else
- SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
@@ -30,16 +30,11 @@ RESTRICT="test" # see bug #236845
LICENSE="MIT"
SLOT="0"
-RDEPEND="elibc_FreeBSD? ( >=dev-libs/libpthread-stubs-0.4:=[${MULTILIB_USEDEP}] )
+RDEPEND="
video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
valgrind? ( dev-util/valgrind )"
-src_unpack() {
- default
- [[ $PV = 9999* ]] && git-r3_src_unpack
-}
-
multilib_src_configure() {
local emesonargs=(
# Udev is only used by tests now.