summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-01 21:40:54 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-01 21:41:08 +0100
commit0aa556416160e9ad6bafd733a64789627f36f1b2 (patch)
tree7217b6cb8a0fd3894673e5ff693176e11b902ecd /x11-libs
parentnet-im/telegram-desktop: Bump to 3.1.11, drop old (diff)
downloadgentoo-0aa556416160e9ad6bafd733a64789627f36f1b2.tar.gz
gentoo-0aa556416160e9ad6bafd733a64789627f36f1b2.tar.bz2
gentoo-0aa556416160e9ad6bafd733a64789627f36f1b2.zip
x11-libs/pango: Do NOT depend on freetype[harfbuzz,png] anymore
This caused ugly circular dependencies between harfbuzz and freetype on just about every initial installation. Minor font rendering issues accompanied by a warning are an acceptable tradeoff. Discussed in detail in releng team Bug: https://bugs.gentoo.org/712374 Bug: https://bugs.gentoo.org/717380 Bug: https://bugs.gentoo.org/813504 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/pango-1.48.10-r1.ebuild (renamed from x11-libs/pango/pango-1.48.10.ebuild)11
-rw-r--r--x11-libs/pango/pango-1.48.7-r2.ebuild (renamed from x11-libs/pango/pango-1.48.7-r1.ebuild)11
2 files changed, 20 insertions, 2 deletions
diff --git a/x11-libs/pango/pango-1.48.10.ebuild b/x11-libs/pango/pango-1.48.10-r1.ebuild
index 0c88d2262013..9eb3d082e26a 100644
--- a/x11-libs/pango/pango-1.48.10.ebuild
+++ b/x11-libs/pango/pango-1.48.10-r1.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
>=media-libs/harfbuzz-2.2.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
>=media-libs/fontconfig-2.12.92:1.0=[${MULTILIB_USEDEP}]
>=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1:2=[harfbuzz,png,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
X? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
@@ -73,3 +73,12 @@ multilib_src_install_all() {
# This will install PangoXft API docs regardless of USE=-X, but this is intentional
doins -r "${S}"/docs/Pango*
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}
diff --git a/x11-libs/pango/pango-1.48.7-r1.ebuild b/x11-libs/pango/pango-1.48.7-r2.ebuild
index aef9e1d9db15..cc225cce0cdc 100644
--- a/x11-libs/pango/pango-1.48.7-r1.ebuild
+++ b/x11-libs/pango/pango-1.48.7-r2.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
>=media-libs/harfbuzz-2.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
>=media-libs/fontconfig-2.12.92:1.0=[${MULTILIB_USEDEP}]
>=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1:2=[harfbuzz,png,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
X? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
@@ -73,3 +73,12 @@ multilib_src_install_all() {
# This will install PangoXft API docs regardless of USE=-X, but this is intentional
doins -r "${S}"/docs/Pango*
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}