summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 23:58:33 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 23:58:33 +0100
commit18ea7472b40c520614ac05b9d9c7ac84d53dbfce (patch)
treed891c011ed113478cefa39ebc2d9df91c178e82c /x11-libs
parenteclass/tests/toolchain-funcs.sh: fix gold tests, bug #700812 (diff)
downloadgentoo-18ea7472b40c520614ac05b9d9c7ac84d53dbfce.tar.gz
gentoo-18ea7472b40c520614ac05b9d9c7ac84d53dbfce.tar.bz2
gentoo-18ea7472b40c520614ac05b9d9c7ac84d53dbfce.zip
x11-libs/xbae: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xbae/files/xbae-4.60.4-Makefile.in.patch4
-rw-r--r--x11-libs/xbae/files/xbae-4.60.4-lxmp.patch4
-rw-r--r--x11-libs/xbae/files/xbae-4.60.4-tmpl.patch4
-rw-r--r--x11-libs/xbae/xbae-4.60.4.ebuild44
4 files changed, 27 insertions, 29 deletions
diff --git a/x11-libs/xbae/files/xbae-4.60.4-Makefile.in.patch b/x11-libs/xbae/files/xbae-4.60.4-Makefile.in.patch
index aa0625b815af..2c16bdf489c0 100644
--- a/x11-libs/xbae/files/xbae-4.60.4-Makefile.in.patch
+++ b/x11-libs/xbae/files/xbae-4.60.4-Makefile.in.patch
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2007-04-03 15:06:53.066980500 +0100
-+++ Makefile.in 2007-04-03 15:16:53.795027250 +0100
+--- a/Makefile.in
++++ b/Makefile.in
@@ -230,14 +230,13 @@
x_includes = @x_includes@
x_libraries = @x_libraries@
diff --git a/x11-libs/xbae/files/xbae-4.60.4-lxmp.patch b/x11-libs/xbae/files/xbae-4.60.4-lxmp.patch
index d5b66015eb0c..8d14303d4d78 100644
--- a/x11-libs/xbae/files/xbae-4.60.4-lxmp.patch
+++ b/x11-libs/xbae/files/xbae-4.60.4-lxmp.patch
@@ -1,5 +1,5 @@
---- examples/Mri/Makefile.in.orig 2007-04-03 14:52:55.326625000 +0100
-+++ examples/Mri/Makefile.in 2007-04-03 14:53:12.731712750 +0100
+--- a/examples/Mri/Makefile.in
++++ b/examples/Mri/Makefile.in
@@ -219,7 +219,7 @@
-I$(top_builddir)/include @MOTIF_CFLAGS@ @X_CFLAGS@
diff --git a/x11-libs/xbae/files/xbae-4.60.4-tmpl.patch b/x11-libs/xbae/files/xbae-4.60.4-tmpl.patch
index 0e87ba3da39c..671cd3f9218d 100644
--- a/x11-libs/xbae/files/xbae-4.60.4-tmpl.patch
+++ b/x11-libs/xbae/files/xbae-4.60.4-tmpl.patch
@@ -1,5 +1,5 @@
---- Xbae.tmpl.orig 2007-04-03 14:45:54.548519000 +0100
-+++ Xbae.tmpl 2007-04-03 14:46:12.053613000 +0100
+--- a/Xbae.tmpl
++++ b/Xbae.tmpl
@@ -13,7 +13,7 @@
#define DoNormalLib YES
diff --git a/x11-libs/xbae/xbae-4.60.4.ebuild b/x11-libs/xbae/xbae-4.60.4.ebuild
index b4d5e7e4ae29..b9fe5e37dde0 100644
--- a/x11-libs/xbae/xbae-4.60.4.ebuild
+++ b/x11-libs/xbae/xbae-4.60.4.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=7
DESCRIPTION="Motif-based widget to display a grid of cells as a spreadsheet"
HOMEPAGE="http://xbae.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="BSD"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
SLOT="0"
-IUSE="doc examples static-libs"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+# tests need X display
+# and are interactive so virtualx will not help
+RESTRICT="test"
RDEPEND="
x11-libs/motif:0
@@ -22,43 +23,40 @@ RDEPEND="
x11-libs/libXmu
x11-libs/libXpm
x11-libs/libXt"
-
DEPEND="${RDEPEND}"
-# tests need X display
-# and are interactive so virtualx will not help
-RESTRICT=test
-
PATCHES=(
"${FILESDIR}"/${P}-tmpl.patch
"${FILESDIR}"/${P}-lxmp.patch
"${FILESDIR}"/${P}-Makefile.in.patch
- )
+)
src_configure() {
- local myeconfargs=( --enable-production )
- autotools-utils_src_configure
+ econf --enable-production
}
src_test() {
- cd ${AUTOTOOLS_BUILD_DIR}/examples
- emake
- "${S}"/examples/testall
- emake clean
+ emake -C examples
+ emake -C examples/testall clean
}
src_install() {
- autotools-utils_src_install
+ default
insinto /usr/share/aclocal
doins ac_find_xbae.m4
- use doc && dohtml -r doc/*
-
if use examples; then
find examples -name '*akefile*' -delete || die
rm examples/{testall,extest} || die
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dodoc -r examples
+ fi
+ if use doc; then
+ rm doc/{,images/}Makefile* || die
+ docinto html
+ dodoc -r doc/.
fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}