summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-12-25 21:58:15 -0500
committerMike Gilbert <floppym@gentoo.org>2020-12-28 12:35:46 -0500
commit2bf13fdab5285b6378d3ac6bafac169d85392e66 (patch)
tree2ab42eebce05bc5e997d18908fb3e1c6609b92af /x11-libs
parentsys-power/upower: use BDEPEND with EAPI 7 (diff)
downloadgentoo-2bf13fdab5285b6378d3ac6bafac169d85392e66.tar.gz
gentoo-2bf13fdab5285b6378d3ac6bafac169d85392e66.tar.bz2
gentoo-2bf13fdab5285b6378d3ac6bafac169d85392e66.zip
x11-libs/libxklavier: EAPI 7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxklavier/libxklavier-5.4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-libs/libxklavier/libxklavier-5.4.ebuild b/x11-libs/libxklavier/libxklavier-5.4.ebuild
index 6506faf579bb..610b2e00fd94 100644
--- a/x11-libs/libxklavier/libxklavier-5.4.ebuild
+++ b/x11-libs/libxklavier/libxklavier-5.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit libtool vala xdg-utils
@@ -27,7 +27,8 @@ RDEPEND="
introspection? ( >=dev-libs/gobject-introspection-1.30:= )
vala? ( $(vala_depend) )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/glib-utils
>=dev-util/gtk-doc-am-1.4
sys-devel/gettext
@@ -54,5 +55,5 @@ src_configure() {
src_install() {
default
dodoc CREDITS
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}