summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-09 13:59:01 -0800
committerMatt Turner <mattst88@gentoo.org>2021-12-09 17:02:22 -0500
commit43ab6b9a156328c7da0539fed067da9718623967 (patch)
tree0989c767542c2dbe818e15e2ba283afe368a8f65 /x11-libs
parentx11-misc/compose-tables: Version bump to 1.7.3 (diff)
downloadgentoo-43ab6b9a156328c7da0539fed067da9718623967.tar.gz
gentoo-43ab6b9a156328c7da0539fed067da9718623967.tar.bz2
gentoo-43ab6b9a156328c7da0539fed067da9718623967.zip
x11-libs/libX11: Version bump to 1.7.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.7.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index b64f51ba668e..9e35ab8f1cdf 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1 +1,2 @@
DIST libX11-1.7.2.tar.bz2 2392982 BLAKE2B ce64bd8172fcf4f5bf0783c4f25f4d220fa0eceb211b7a852802256f7241f543769565f70a59c1ff14e0bb1ae7d3f05914f8f0b1bd423dcb20181cfb2227c70d SHA512 d01e5c1848c76218605e5af2d353de6b301a251555b52a38dbe930e6635d5e8a92d1486eb6d328ad5d42a5939e0d16868ffa19a75e5a7863d1a32e0d0727bdc7
+DIST libX11-1.7.3.tar.xz 1861304 BLAKE2B e0f647ef55567b1d7eff74bc053b8e73f8c696be6f233c2ff6f64dee65c1b40b746683ea7a6fafb4304eba4dec43301b4b3506e2ec6fac1d4c89d664b516bbdd SHA512 abc70837d19f7e104a5db1e6d2cfa1256625332c0b53fec44a0a39916a60a430bb53fd436207892aabe4199ac7a0f9287a06588fcd27e0eed54d45d67bbe1294
diff --git a/x11-libs/libX11/libX11-1.7.3.ebuild b/x11-libs/libX11/libX11-1.7.3.ebuild
new file mode 100644
index 000000000000..bc2f07298e05
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.7.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit toolchain-funcs xorg-3
+
+# Note: please bump this with x11-misc/compose-tables
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}