summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-08-15 16:12:34 -0400
committerMatt Turner <mattst88@gentoo.org>2020-08-16 17:08:57 -0700
commit519e66cd19eee5488190e4d8cf8807e57ff6f22d (patch)
tree68e24fa32e8f9b1c865f8a30710be98102031c44 /x11-libs
parentx11-libs/xcb-util-wm: EAPI 7 (diff)
downloadgentoo-519e66cd19eee5488190e4d8cf8807e57ff6f22d.tar.gz
gentoo-519e66cd19eee5488190e4d8cf8807e57ff6f22d.tar.bz2
gentoo-519e66cd19eee5488190e4d8cf8807e57ff6f22d.zip
x11-libs/xcb-util-xrm: EAPI 7
Drop the eclass URI definition since it gets overridden anyway. Drop the doc USE flag since it has no effect. (There is a Doxyfile in the repo that is not included in the release archive.) Drop the test USE flag since there are no dependencies. Rebuild on libxcb slot changes like every other xcb-util package. Add xorg-proto as a build-time dependency. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xcb-util-xrm/xcb-util-xrm-1.3-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3-r1.ebuild b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3-r1.ebuild
new file mode 100644
index 000000000000..d442dae06839
--- /dev/null
+++ b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/"
+SRC_URI="https://github.com/Airblader/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libX11[${MULTILIB_USEDEP}]" # Only for tests, but configure.ac requires it