summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-15 23:34:20 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-15 23:34:20 +0200
commit5e70371d618e0736a9e40d4e21527d11c2e4e36b (patch)
treeaf4725cc470dd2924da29ca5078838d77eaafc2c /x11-libs
parentlxqt-base/lxqt-runner: Version bump to 0.11.0 (diff)
downloadgentoo-5e70371d618e0736a9e40d4e21527d11c2e4e36b.tar.gz
gentoo-5e70371d618e0736a9e40d4e21527d11c2e4e36b.tar.bz2
gentoo-5e70371d618e0736a9e40d4e21527d11c2e4e36b.zip
x11-libs/libnotify: Version bump to 0.7.7
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libnotify/Manifest1
-rw-r--r--x11-libs/libnotify/libnotify-0.7.7.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index 2f6b157a9631..af7d53b8189c 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1 +1,2 @@
DIST libnotify-0.7.6.tar.xz 280388 SHA256 0ef61ca400d30e28217979bfa0e73a7406b19c32dd76150654ec5b2bdf47d837 SHA512 5d656ee7ee5caeb95aec4adb973795dc72fc620cd36b9fe3d4f910951945bd5df70ee1c422cd6aca9c38a9ba2760562e479fc8fb9269449924a5b24d762d03df WHIRLPOOL e619c8d10790f5b78730a2599c407bc951de68b189f460c72999776eaf92014aded0953ca06398cce7ad09fd8c87e1c7727cea4f4c81eccee0a8b2f2bafd195b
+DIST libnotify-0.7.7.tar.xz 285356 SHA256 9cb4ce315b2655860c524d46b56010874214ec27e854086c1a1d0260137efc04 SHA512 133874114407bf12267ef609f5941657181760bc7cf115c5973b1810cb72bf55072b621c143e32be1e7e8b49f244851925d14bc3f9f26457747b8a8695ee9954 WHIRLPOOL 61281729f3369c817183e9503cecad4a4264834cf91548e0bd4ea0a827b97ae15be0e4a7ed0a4287f72e14661cc199f37c711ec2d36a613fc94a1d9dc294dce7
diff --git a/x11-libs/libnotify/libnotify-0.7.7.ebuild b/x11-libs/libnotify/libnotify-0.7.7.ebuild
new file mode 100644
index 000000000000..0c6b8bd3842c
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome.org multilib-minimal xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://git.gnome.org/browse/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ app-eselect/eselect-notify-send
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.32
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ xdg_environment_reset
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+
+ if ! use test; then
+ sed -i -e '/PKG_CHECK_MODULES(TESTS/d' configure.ac || die
+ fi
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf \
+ --disable-static \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/html docs/reference/html || die
+ fi
+}
+
+multilib_src_install() {
+ default
+ prune_libtool_files
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}