summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-04-02 11:43:53 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-04-02 11:46:46 +0200
commit7bde75d74687af9ba5a77474ea458c01666febc8 (patch)
treea11014da3a42f701a774ca50aad1b2374a43a3b1 /x11-libs
parentx11-libs/pango: raise dependency on fontconfig (diff)
downloadgentoo-7bde75d74687af9ba5a77474ea458c01666febc8.tar.gz
gentoo-7bde75d74687af9ba5a77474ea458c01666febc8.tar.bz2
gentoo-7bde75d74687af9ba5a77474ea458c01666febc8.zip
x11-libs/pango: version bump 1.40.14-r1 → 1.42.0
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.42.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index 0321d7f3d8b0..556d4720d9f8 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -1,2 +1,3 @@
DIST pango-1.40.12.tar.xz 856228 BLAKE2B c6fe562f64ac7b641b5b8519f831b999418ab06c1686ac07aa08b587bfba761a834e698f033bdb79666ea6ddd6c1f672ce968897c7594e4467c5b6dee644877e SHA512 772792edac9ab5b6f76617cd3512432ca6b9af1d5ee6bfb87d0b60293f560026d479df059da66f53ba567f916a275e82f1cdd17ca75bb0da7ae2a79d4a75ed6d
DIST pango-1.40.14.tar.xz 858388 BLAKE2B 1afcff08c38aa59ec57cdf43aa503e70a8c03b7d59c730060c9e3537f78ffe9a63e3aa1cb74ce9ce8d72541b5a5be8becb951f665f4663b108114686c41452c8 SHA512 35ba7bc8be3992f206ccc2cc5aca0b94e2a3832f887fc9c45b0e29fddcb9051ce05a74377de0ca4ff95a87983b15688fa5d379d592faf87aa8eaca25ac18b7ea
+DIST pango-1.42.0.tar.xz 824984 BLAKE2B 2ea7b5d0d95c91b61ad8f841e75d7431f405ba1c1a01acef52364d3143c4e99f6ba66d03b52e7e94d4074edc7a116e4c9ffa16b7538851a82ec0b638c8f83f05 SHA512 32f621f7af65102ddf7f5ad949c1a9da9a559259255de42a6c0e7992b8692088f6701a4e11558c4243edc881cb8907defd6712f4c2bfca4bcadfe1cb5009b59f
diff --git a/x11-libs/pango/pango-1.42.0.ebuild b/x11-libs/pango/pango-1.42.0.ebuild
new file mode 100644
index 000000000000..6f6620c9c4d6
--- /dev/null
+++ b/x11-libs/pango/pango-1.42.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2+ FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="X +introspection test"
+
+RDEPEND="
+ >=media-libs/harfbuzz-1.2.3:=[glib(+),truetype(+),${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.12.92:1.0=[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.14-r4:=[X?,${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-0.19.7[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( media-fonts/cantarell )
+ X? ( >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
+ !<=sys-devel/autoconf-2.63:2.5
+"
+
+multilib_src_configure() {
+ tc-export CXX
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --with-cairo \
+ $(multilib_native_use_enable introspection) \
+ $(use_with X xft) \
+ "$(usex X --x-includes="${EPREFIX}/usr/include" "")" \
+ "$(usex X --x-libraries="${EPREFIX}/usr/$(get_libdir)" "")"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}