summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-23 16:13:36 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-23 16:15:10 +0300
commit8278df149dfe6d951c8afc66d4c39d23a2811ada (patch)
tree4ad37f172740e5261036d94f01c93f149dfdc6c1 /x11-libs
parentgnome-extra/libgsf: bump to 1.14.43 (diff)
downloadgentoo-8278df149dfe6d951c8afc66d4c39d23a2811ada.tar.gz
gentoo-8278df149dfe6d951c8afc66d4c39d23a2811ada.tar.bz2
gentoo-8278df149dfe6d951c8afc66d4c39d23a2811ada.zip
x11-libs/gtk+: bump to 3.22.30; stable wayland xdg-shell protocol support
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/Manifest1
-rw-r--r--x11-libs/gtk+/gtk+-3.22.30.ebuild231
2 files changed, 232 insertions, 0 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 62206f96d7e2..75cf5c490bcd 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -2,3 +2,4 @@ DIST gtk+-2.24.31.tar.xz 12805344 BLAKE2B f516f9970a95afa21ae5dbe9f0cafd3c57c5cd
DIST gtk+-3.22.19.tar.xz 18841024 BLAKE2B dc4c27d022c6766036b16e52b53b4aa3946c41457abaabca390bdba2b720db71b9c584101990928af1bef73dc49f7b71a951ba0000bd52e11aa5306a1d877f18 SHA512 c83198794433ee6eb29f8740d59bd7056cd36808b4bff1a99563ab1a1742e6635dab4f2a8be33317f74d3b336f0d1adc28dd91410da056b50a08c215f184dce2
DIST gtk+-3.22.26.tar.xz 18922136 BLAKE2B a1e43be24abe2bda8eb63f3794b191b152abb5717334f8f46fe3158eb7ec92d5413ed3ca0df2a1ad676deacee3e7ce5e737661ec5f5c911609d40d3b9379c4c4 SHA512 2fd3a4175168d37f243359bac5df84722a2830fe5b62f86b914ce39ff500f0361e412843922343dffef8bee8f1205799ff86dd3ae8ac419928f4fe977e0e946f
DIST gtk+-3.22.29.tar.xz 18964852 BLAKE2B a7551d604a1e27cba1d0580f2645bf4afff900908ce40d3d4d05cfb7348afc0620922e9b7939cf4ce2314ff489ffe38386aaf2634f3eff6591dfd0a225f19bc7 SHA512 046fa4458626e81ea7b1ddb753d53ecd91d0f2101af428cfdf77fe866bbe430cb3622203cc5e895b220a9364e35009245cdaf76e0cfa30d32d31095b5fcb42bc
+DIST gtk+-3.22.30.tar.xz 18946084 BLAKE2B 020512f61ae9d265849bb684c55c6ad3f1e1726d73ce169cd482e781e614f22f37ac23bc721b1dc11df03f0d4e07333266cc8549633cb255ca99a85a499108d3 SHA512 31440a615cb2f406d0f904e59febb8f876106f27818ddd6951c76ab9bcb421ca480dae2bebfb1c4b1e03b833fc7c42e9feede053d9d71f19a02fe778e3197b38
diff --git a/x11-libs/gtk+/gtk+-3.22.30.ebuild b/x11-libs/gtk+/gtk+-3.22.30.ebuild
new file mode 100644
index 000000000000..4f99d0d75ca0
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.22.30.ebuild
@@ -0,0 +1,231 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools flag-o-matic gnome2 multilib virtualx multilib-minimal
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+IUSE="aqua broadway cloudprint colord cups examples +introspection test vim-syntax wayland +X xinerama"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ xinerama? ( X )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Upstream wants us to do their job:
+# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1
+RESTRICT="test"
+
+# FIXME: introspection data is built against system installation of gtk+:3,
+# bug #????
+COMMON_DEPEND="
+ >=dev-libs/atk-2.15[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.49.4:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ >=media-libs/libepoxy-1.0[X(+)?,${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.14[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.37.3[introspection?,${MULTILIB_USEDEP}]
+ x11-misc/shared-mime-info
+
+ cloudprint? (
+ >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
+ >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
+ colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.39:= )
+ wayland? (
+ >=dev-libs/wayland-1.9.91[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.12
+ media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+ >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.5[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-libs/gobject-introspection-common
+ >=dev-util/gdbus-codegen-2.48
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.19.7[${MULTILIB_USEDEP}]
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ X? (
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/inputproto[${MULTILIB_USEDEP}]
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ xinerama? ( x11-proto/xineramaproto[${MULTILIB_USEDEP}] )
+ )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )
+"
+# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
+# gtk+-3.3.18 breaks scrolling in <=x11-libs/vte-0.31.0:2.90
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+ !<gnome-base/gail-1000
+ !<x11-libs/vte-0.31.0:2.90
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ gnome-base/librsvg[${MULTILIB_USEDEP}]
+ >=x11-themes/adwaita-icon-theme-3.14
+ vim-syntax? ( app-vim/gtk-syntax )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gtk-query-immodules-3.0$(get_exeext)
+)
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ if ! use test ; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS testsuite Makefile.{am,in}
+
+ # the tests dir needs to be build now because since commit
+ # 7ff3c6df80185e165e3bf6aa31bd014d1f8bf224 tests/gtkgears.o needs to be there
+ # strip_builddir SRC_SUBDIRS tests Makefile.{am,in}
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.{am,in}
+ strip_builddir SRC_SUBDIRS examples Makefile.{am,in}
+ fi
+
+ # gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache
+ eapply "${FILESDIR}"/${PN}-3.22.2-update-icon-cache.patch
+
+ # Fix broken autotools logic
+ eapply "${FILESDIR}"/${PN}-3.22.20-libcloudproviders-automagic.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ # cloudprovider is not packaged in Gentoo
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(use_enable aqua quartz-backend) \
+ $(use_enable broadway broadway-backend) \
+ $(use_enable cloudprint) \
+ $(use_enable colord) \
+ $(use_enable cups cups auto) \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable wayland wayland-backend) \
+ $(use_enable X x11-backend) \
+ $(use_enable X xcomposite) \
+ $(use_enable X xdamage) \
+ $(use_enable X xfixes) \
+ $(use_enable X xkb) \
+ $(use_enable X xrandr) \
+ $(use_enable xinerama) \
+ --disable-cloudproviders \
+ --disable-mir-backend \
+ --disable-papi \
+ --enable-man \
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ local d
+ for d in gdk gtk libgail-util; do
+ ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx emake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+ # Skip README.{in,commits,win32} and useless ChangeLog that would get installed by default
+ DOCS=( AUTHORS NEWS README )
+ einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ multilib_pkg_preinst() {
+ # Make immodules.cache belongs to gtk+ alone
+ local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+ multilib_parallel_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_query_immodules_gtk3 \
+ || die "Update immodules cache failed (for ${ABI})"
+ }
+ multilib_parallel_foreach_abi multilib_pkg_postinst
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ multilib_pkg_postrm() {
+ rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+ fi
+}