summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-14 12:30:34 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-14 13:23:05 +0300
commit8ec93c2471dee5383d9c5fb839ee3885ca83e998 (patch)
tree3f972146aaaf6156b33db88c2c742af9eda8a4ad /x11-libs
parentdev-db/postgresql-9.5.14-r0: alpha stable (diff)
downloadgentoo-8ec93c2471dee5383d9c5fb839ee3885ca83e998.tar.gz
gentoo-8ec93c2471dee5383d9c5fb839ee3885ca83e998.tar.bz2
gentoo-8ec93c2471dee5383d9c5fb839ee3885ca83e998.zip
x11-libs/libwnck: bump to 3.30.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libwnck/Manifest1
-rw-r--r--x11-libs/libwnck/libwnck-3.30.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-libs/libwnck/Manifest b/x11-libs/libwnck/Manifest
index 95a64fdd7307..417a185c59c4 100644
--- a/x11-libs/libwnck/Manifest
+++ b/x11-libs/libwnck/Manifest
@@ -1,2 +1,3 @@
DIST libwnck-2.31.0.tar.xz 630792 BLAKE2B 8201537d3c9a8a0a8668fc16d33a8eaa05c14312401f1c763c922402df04ef03260dd259f5c46508f85390f7aefd551e83143e654b24b412272dddb7c7c4bd62 SHA512 54262a08882021f08f3ba7f2ddfa33fc1f02e391a0f61cf999a50a089e0d277dfe13ab133c1a46e9abf0599bd24c21dacff80b51013cbb1375d2cd71ac9abbe9
DIST libwnck-3.24.1.tar.xz 821508 BLAKE2B 18bc01a08107e0b2b040cb6036a80cb289955aa9365b7568292aa1c29dc77758bc9b11caa57b8cff6bebb75dd1d0bf7135b0cebed1e42c6ccc1c1372c6a224b5 SHA512 e8a31ab2dc0c282f1e0994ce6a2ccd18678dc5c140943399262e795052b7f5da2d6a5d388a74f4b10f8fac66ab138983a9caaee4e72c92a17c01ca5c39b731e1
+DIST libwnck-3.30.0.tar.xz 800296 BLAKE2B 5917ac8a69f6f1e0d639f301a77349015226ca6d0fc12e8b23c00a81e18f6e9dbb7716b01e50aceb15bdbd64b5b1a8295be5b931d513e120508cdf14d2d15a23 SHA512 79842e4645de828941ac030eeff9d232b18a51fe0d18baf5ceb2beaf897d328ee5bf3b297501e2b27e66c63d42f6546a7605a37c6d7d52ff76e9b2bc5c328128
diff --git a/x11-libs/libwnck/libwnck-3.30.0.ebuild b/x11-libs/libwnck/libwnck-3.30.0.ebuild
new file mode 100644
index 000000000000..05d20f984b74
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-3.30.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="https://developer.gnome.org/libwnck/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE="+introspection startup-notification tools"
+
+RDEPEND="
+ x11-libs/cairo[X]
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=dev-libs/glib-2.32:2
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+# eautoreconf needs
+# sys-devel/autoconf-archive
+
+src_configure() {
+ # Don't collide with SLOT=1
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable startup-notification) \
+ $(use_enable tools) \
+ --program-suffix=-${SLOT}
+}