summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-11-24 22:50:12 -0800
committerMatt Turner <mattst88@gentoo.org>2021-11-24 22:52:11 -0800
commit900b3794ce1d3051d4bf398cd4efc2ed00b3f393 (patch)
tree7212c7765c35c899f721c37ae81a7f6b88fd07dc /x11-libs
parentdev-libs/wayland-protocols: Version bump to 1.24 (diff)
downloadgentoo-900b3794ce1d3051d4bf398cd4efc2ed00b3f393.tar.gz
gentoo-900b3794ce1d3051d4bf398cd4efc2ed00b3f393.tar.bz2
gentoo-900b3794ce1d3051d4bf398cd4efc2ed00b3f393.zip
x11-libs/libdrm: Version bump to 2.4.108
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.108.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 49988eb4a988..f682930ffe8b 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1,2 +1,3 @@
DIST libdrm-2.4.106.tar.xz 418176 BLAKE2B b0f935297239560179ec8994b62c7161494d4c1aa33bbfdc4d5e4ecff97d252f7556575391ebf486e24257c365415e656b9f84ac883dc9d56baf39e79ff8c5f2 SHA512 33140e579906ab54b716149056af500c628ce41cd9ae3b0c33496693d2f5903fbcfccee8a942dd1560e1591111ed240da42612d5af5e75558db6f6a85d14617d
DIST libdrm-2.4.107.tar.xz 425612 BLAKE2B a685cd9a6549c7bdf1efb4e7ebddd0ea49554fa718f8328c868a1f245e7c072933e49546591c056ba7ece8d8841b8138e4247dd8697238a18c2cd92fe5446341 SHA512 c7542ba15c4c934519a6a1f3cb1ec21effa820a805a030d0175313bb1cc796cd311f39596ead883f9f251679d701e262894c5a297d5cf45093c80a6cd818def0
+DIST libdrm-2.4.108.tar.xz 432492 BLAKE2B 943107e4ece51336c2cec690b2805cac3ebe4502c548401ba7add1b1cdcb6c9959e4a9fe75890438e0b30646f8dde1b322585544aa33abb5257a23cc3eeed3ab SHA512 6a841dc3eb8eae7d75e1d35d23a14d51aff758e5a251dbcf6fc8c28d973d935a4a2f6751b405e956b2777d93c651721199ac80c3cd14b87d021668120d6bc974
diff --git a/x11-libs/libdrm/libdrm-2.4.108.ebuild b/x11-libs/libdrm/libdrm-2.4.108.ebuild
new file mode 100644
index 000000000000..c34f20fb240d
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.108.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/drm.git"
+PYTHON_COMPAT=( python3_{8..10} )
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} python-any-r1 meson-multilib
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')"
+
+python_check_deps() {
+ has_version -b "dev-python/docutils[${PYTHON_USEDEP}]"
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Udev is only used by tests now.
+ -Dudev=false
+ -Dcairo-tests=false
+ $(meson_use video_cards_amdgpu amdgpu)
+ $(meson_use video_cards_exynos exynos)
+ $(meson_use video_cards_freedreno freedreno)
+ $(meson_use video_cards_intel intel)
+ $(meson_use video_cards_nouveau nouveau)
+ $(meson_use video_cards_omap omap)
+ $(meson_use video_cards_radeon radeon)
+ $(meson_use video_cards_tegra tegra)
+ $(meson_use video_cards_vc4 vc4)
+ $(meson_use video_cards_vivante etnaviv)
+ $(meson_use video_cards_vmware vmwgfx)
+ $(meson_use libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ -Dvalgrind=$(usex valgrind auto false)
+ )
+ meson_src_configure
+}