summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 19:39:50 +0000
committerSam James <sam@gentoo.org>2021-03-16 19:56:13 +0000
commita16402ab4e35fbf01769346cd4abca30a584fd6a (patch)
tree74c92adbb1d670ba0f41c3d574fd570f2b75d810 /x11-libs
parentx11-misc/gpaste: drop 3.20.3 (diff)
downloadgentoo-a16402ab4e35fbf01769346cd4abca30a584fd6a.tar.gz
gentoo-a16402ab4e35fbf01769346cd4abca30a584fd6a.tar.bz2
gentoo-a16402ab4e35fbf01769346cd4abca30a584fd6a.zip
x11-libs/fox-wrapper: drop 2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fox-wrapper/files/fox-wrapper-2.sh75
-rw-r--r--x11-libs/fox-wrapper/fox-wrapper-2.ebuild26
2 files changed, 0 insertions, 101 deletions
diff --git a/x11-libs/fox-wrapper/files/fox-wrapper-2.sh b/x11-libs/fox-wrapper/files/fox-wrapper-2.sh
deleted file mode 100644
index 19d09b5b9ca6..000000000000
--- a/x11-libs/fox-wrapper/files/fox-wrapper-2.sh
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Based on the am-wrapper.sh script (sys-devel/automake-wrapper-1-r1)
-#
-# Executes the correct fox-config version, based on the value of WANT_FOX.
-# All versions of fox after 1.0.x ship with a fox-config script
-#
-#
-# Stable branches first, in descending order, then unstable branches.
-# After a new stable branch, prepend the new version and bump (or remove)
-# the last unstable branch
-#
-vers="1.6 1.4 1.2 1.5"
-bindir=/usr/bin
-
-if [ "${0##*/}" = "fox-wrapper.sh" ] ; then
- echo "fox-wrapper: Don't call this script directly, use fox-config instead" >&2
- exit 1
-fi
-
-if [ -z "${WANT_FOX}" ] ; then
- echo "fox-wrapper: Set the WANT_FOX variable to the desired version of fox, e.g.:" >&2
- echo " WANT_FOX=\"1.2\" fox-config $@"
- exit 1
-fi
-
-for v in ${vers} ; do
- eval binary_${v/./_}="fox-${v}-config"
-done
-
-#
-# Check the WANT_FOX setting
-#
-for v in ${vers} x ; do
- if [ "${v}" = "x" ] ; then
- echo "fox-wrapper: WANT_FOX was set to an invalid version ${WANT_FOX}" >&2
- echo " Valid values of WANT_FOX are: ${vers// /, }"
- exit 1
- fi
-
- if [ "${WANT_FOX}" = "${v}" ] ; then
- binary="binary_${v/./_}"
- binary="${!binary}"
- break
- fi
-done
-
-if [ "${WANT_FOXWRAPPER_DEBUG}" ] ; then
- echo "fox-wrapper: DEBUG: WANT_FOX is set to ${WANT_FOX}" >&2
- echo "fox-wrapper: DEBUG: will execute <$binary>" >&2
-fi
-
-#
-# for further consistency
-#
-for v in ${vers} ; do
- mybin="binary_${v/./_}"
- if [ "${binary}" = "${!mybin}" ] ; then
- export WANT_FOX="${v}"
- fi
-done
-
-#
-# Now try to run the binary
-#
-if [ ! -x "${bindir}/${binary}" ] ; then
- echo "fox-wrapper: $binary is missing or not executable." >&2
- echo " Please try emerging the correct version of fox, i.e.:" >&2
- echo " emerge '=x11-libs/${binary/-config/}*'" >&2
- exit 1
-fi
-
-"$binary" "$@"
diff --git a/x11-libs/fox-wrapper/fox-wrapper-2.ebuild b/x11-libs/fox-wrapper/fox-wrapper-2.ebuild
deleted file mode 100644
index eeb9dd5e6bac..000000000000
--- a/x11-libs/fox-wrapper/fox-wrapper-2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="wrapper for fox-config to manage multiple versions"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-S=${WORKDIR}
-
-src_install() {
- exeinto /usr/lib/misc
- newexe "${FILESDIR}"/fox-wrapper-${PV}.sh fox-wrapper.sh
-
- dodir /usr/bin
- dosym ../lib/misc/fox-wrapper.sh /usr/bin/fox-config
-}