summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-30 23:10:31 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-30 23:10:31 +0200
commita7e2be1faba302a3e02bd9fc8226a22ad79e950c (patch)
treea9001e84a7aaf930b13c6682077469876c4ab827 /x11-libs
parentdev-libs/intel-compute-runtime: bump to version 21.43.21438 (diff)
downloadgentoo-a7e2be1faba302a3e02bd9fc8226a22ad79e950c.tar.gz
gentoo-a7e2be1faba302a3e02bd9fc8226a22ad79e950c.tar.bz2
gentoo-a7e2be1faba302a3e02bd9fc8226a22ad79e950c.zip
x11-libs/libva-intel-media-driver: bump to version 21.4.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva-intel-media-driver/Manifest1
-rw-r--r--x11-libs/libva-intel-media-driver/libva-intel-media-driver-21.4.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/libva-intel-media-driver/Manifest b/x11-libs/libva-intel-media-driver/Manifest
index 0aa8033099df..42890e41964f 100644
--- a/x11-libs/libva-intel-media-driver/Manifest
+++ b/x11-libs/libva-intel-media-driver/Manifest
@@ -8,3 +8,4 @@ DIST intel-media-21.2.3.tar.gz 23025524 BLAKE2B 0652563f8e8494c9fa181822a7af348c
DIST intel-media-21.3.2.tar.gz 23069924 BLAKE2B cb7035698bc19eb65f0cf338e7fb0e11a379a27c243566b6f884d63897da10e2ded39523fcc81131f41885508d1413e7960e38cf9cf2d129d7a6a3994fa9b384 SHA512 27a1849ed2f2367e5de63189faa6e14a1a23f6708c45392f661fab819f856bb4a3d0d31754213b084c4f05be3b155b0a80c2f4e330c79879597910f77e3f1597
DIST intel-media-21.3.3.tar.gz 23092541 BLAKE2B 083cc368095bbc9cf333953855ad94d7a8d633337b967f4f93d94e3c8e23bbcdadad19c1b1032cafc671ae9a9df9be547498ebe84426ad9d91a9e82557095eb8 SHA512 a9da8a627420c5ea0de9413ce0aeb471f40a0886abd67380ead7ffba32de4abbc1741c47cfcfc73d42b14456090266f4dad8d363c8ad590cef521ef48e42f692
DIST intel-media-21.3.5.tar.gz 23110985 BLAKE2B 1dbbc1efa9ae2c8f3b4a34596c71173101f8a43591bf9e07d269a8499b7a57969d9af5c1d4ffb7774a6947947e572b441f871760d3ca695335bfa2976ac2cf6f SHA512 e7836b19050677e81aa34ce5d7cea661ca3b5ac55d73d5aa0bab93f1daba8ee010d84b1c585f62fcec65a4361ef2b7f14ed574858f56b85b4c4d59840ecb6cb6
+DIST intel-media-21.4.0.tar.gz 23116624 BLAKE2B d913e379c4990bd0f5a5d07654baeb374d3b4f7adbe607338a96ac6555631560005d6124fb0124bafe5e94107b54acdfd0fbcfdabc820210b453ebb61c828c36 SHA512 e338e645677d90d4c2e91d5096a9002b87cec602ec354283b67e4ee31fcd6a2454918c4e179b86189126d30742ab2814bc8400072fb1d06638c3bc0bf66385e4
diff --git a/x11-libs/libva-intel-media-driver/libva-intel-media-driver-21.4.0.ebuild b/x11-libs/libva-intel-media-driver/libva-intel-media-driver-21.4.0.ebuild
new file mode 100644
index 000000000000..15ca5a26b62c
--- /dev/null
+++ b/x11-libs/libva-intel-media-driver/libva-intel-media-driver-21.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/media-driver"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ MY_PV="${PV%_pre}"
+ SRC_URI="https://github.com/intel/media-driver/archive/intel-media-${MY_PV}.tar.gz"
+ S="${WORKDIR}/media-driver-intel-media-${MY_PV}"
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~amd64"
+ fi
+fi
+
+DESCRIPTION="Intel Media Driver for VAAPI (iHD)"
+HOMEPAGE="https://github.com/intel/media-driver"
+
+LICENSE="MIT BSD"
+SLOT="0"
+IUSE="+custom-cflags set-as-default test X"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=media-libs/gmmlib-21.3.1
+ >=x11-libs/libva-2.13.0[X?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.0_x11_optional.patch
+ "${FILESDIR}"/${PN}-21.2.2_custom_cflags.patch
+ "${FILESDIR}"/${PN}-20.4.5_testing_in_src_test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEDIA_BUILD_FATAL_WARNINGS=OFF
+ -DMEDIA_RUN_TEST_SUITE=$(usex test)
+ -DBUILD_TYPE=Release
+ -DPLATFORM=linux
+ -DUSE_X11=$(usex X)
+ -DLATEST_CPP_NEEDED=ON # Seems to be the best option for now
+ -DOVERRIDE_COMPILER_FLAGS=$(usex !custom-cflags)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use set-as-default ; then
+ echo 'LIBVA_DRIVER_NAME="iHD"' > "${T}/55libva-intel-media-driver" || die
+ doenvd "${T}/55libva-intel-media-driver"
+ fi
+}