summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-07-31 12:38:49 -0700
committerMatt Turner <mattst88@gentoo.org>2020-07-31 12:42:14 -0700
commita8d6ca4533b82ae5ba111fa3306fde5503e458b6 (patch)
tree0bb3a32b38c863610228ebeaf770e4e3c7b96792 /x11-libs
parentprofiles/arch/riscv: mask cmake[doc], json-c[doc] (diff)
downloadgentoo-a8d6ca4533b82ae5ba111fa3306fde5503e458b6.tar.gz
gentoo-a8d6ca4533b82ae5ba111fa3306fde5503e458b6.tar.bz2
gentoo-a8d6ca4533b82ae5ba111fa3306fde5503e458b6.zip
x11-libs/libX11: Version bump to 1.6.10
Bug: https://bugs.gentoo.org/734974 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.6.10.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index 7b7ca0feb3c7..0a3ba78b4cd2 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1 +1,2 @@
+DIST libX11-1.6.10.tar.bz2 2294095 BLAKE2B de615b3fb95e709f3e7b4f91c21b7f29adedb591afd76d8e631ea1d88a54530d799c840de6f5ee1af2a5aa48dfb87bc20dcbed2a2902d707ea3c198ec24d8d86 SHA512 ad384d8896fbe587f7fd99b0d3cc56fac6e2facbab52fa99174200d06b19dd163a483c998acf3834b3a4a3aa4de0dbbe13919a1c80e6797afe467c7075b403ff
DIST libX11-1.6.9.tar.bz2 2283814 BLAKE2B 00fb965b9cd19bde79c4e598c677d21058c85a8ac37d9addab7fb0b2faf67e3d65b91e1864bcd7180e5fd8b0ab7ec3cf68ae7f95ac8e82a049529b5a139b43bd SHA512 fc18f0dc17ade1fc37402179f52e1f2b9c7b7d3a1a9590fea13046eb0c5193b4796289431cd99388eac01e8e59de77db45d2c9675d4f05ef8cf3ba6382c3dd31
diff --git a/x11-libs/libX11/libX11-1.6.10.ebuild b/x11-libs/libX11/libX11-1.6.10.ebuild
new file mode 100644
index 000000000000..64cf1376c979
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.6.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ !<x11-base/xorg-proto-2019.2"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ )
+}