summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-01-29 04:09:17 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-01-29 04:09:33 +1100
commitaf3fb6e5c4b6a26bc87f05ef27e16a8966671b84 (patch)
treeeecfd33068c1f715db03aca1a358ca3c7fc74c98 /x11-libs
parentkde-apps/kdepimlibs: avoid false warning about missing NEEDED (diff)
downloadgentoo-af3fb6e5c4b6a26bc87f05ef27e16a8966671b84.tar.gz
gentoo-af3fb6e5c4b6a26bc87f05ef27e16a8966671b84.tar.bz2
gentoo-af3fb6e5c4b6a26bc87f05ef27e16a8966671b84.zip
x11-libs/snorenotify: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/snorenotify/Manifest1
-rw-r--r--x11-libs/snorenotify/snorenotify-0.7.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/snorenotify/Manifest b/x11-libs/snorenotify/Manifest
index 4a71a24ecead..7cc5f8a23e1e 100644
--- a/x11-libs/snorenotify/Manifest
+++ b/x11-libs/snorenotify/Manifest
@@ -1 +1,2 @@
DIST snorenotify-0.6.0.tar.xz 198376 SHA256 d221bed77abec2d0e7c6120e63ca5f3f4b0193d84fdec497d61ab1159c85269e SHA512 0fa082dcfc8586a75df171918cde8ea86d4ea40646791a1e6f2818181d1318c3c53a281aa25bba16cae62ea2e39b2f718e0f752eac5d8f6ea71bbb9cee961dac WHIRLPOOL c33c9c12a885b3f2967665d09a8fc7e8ad8b6511c60f47845b5cfc2e4c24ff32e541ef18463fd707e4aae8d5d84958102aaf65e286ce3be9cdf965e52c32f7f0
+DIST snorenotify-0.7.0.tar.xz 200032 SHA256 6d411ba6e31a73db56d298195f8336f66f8fe4fffd64d5fde3f14090e68ee64b SHA512 2030a7b6bc69d3803e83e1a6d26efa5bfdd3facf53dcaade6059b85cea3db879ea49b9e02dbce3b043b4ddded21509a6d5859a4002cfd57a870a0e39cd11011a WHIRLPOOL f9be5e7d22724e31d82b633bfc5943a0f767e567d68c4c98edcfb8dadd1797c7c3e8942ac88282d0bb40612e886d70d5874a1c5407631001aa26fcb03c8da5e7
diff --git a/x11-libs/snorenotify/snorenotify-0.7.0.ebuild b/x11-libs/snorenotify/snorenotify-0.7.0.ebuild
new file mode 100644
index 000000000000..9980b28a5f62
--- /dev/null
+++ b/x11-libs/snorenotify/snorenotify-0.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils virtualx
+
+DESCRIPTION="Multi platform Qt notification framework"
+HOMEPAGE="https://techbase.kde.org/Projects/Snorenotify"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sound test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ sound? ( dev-qt/qtmultimedia:5 )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package sound Qt5Multimedia)
+ $(cmake-utils_use_find_package test Qt5Test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ virtx cmake-utils_src_test
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}