summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-27 17:08:36 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-27 17:08:36 -0400
commitcc5ef5be7ff8c92b91f46ede261abc87a3347adf (patch)
tree9158bee9df88172b72bcbb6be6c0277786ea1106 /x11-libs
parentx11-libs/gdk-pixbuf: Version bump to 2.42.4 (diff)
downloadgentoo-cc5ef5be7ff8c92b91f46ede261abc87a3347adf.tar.gz
gentoo-cc5ef5be7ff8c92b91f46ede261abc87a3347adf.tar.bz2
gentoo-cc5ef5be7ff8c92b91f46ede261abc87a3347adf.zip
x11-libs/pango: Version bump to 1.48.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.48.4.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index 33c71b27a7dc..f9c3ba98fe1c 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -2,3 +2,4 @@ DIST pango-1.42.4-patchset.tar.xz 6040 BLAKE2B ec3f1a6a4de30e0864e7f0bf0950cb7a7
DIST pango-1.42.4.tar.xz 833876 BLAKE2B 7de1094a29750b9e59ea1e5c92644fa5d6b835828d027963a53cce3f204ee1ea0042ec492e209de9136f05ca131ccda959bc477d4f6e9c72e5f620ddf4235f26 SHA512 993e97f647eba0c5ed90bcfcb8228bf67fa3f20b1f4331e4e40a30788d7c3ac55eee1209471bf21df125cb8fc6121acc8062a9da2f8a7d6cbe8e9ad13a9320dc
DIST pango-1.44.7.tar.xz 521384 BLAKE2B 9917efc1bcc9115331149d77eb9b15373d4331ed6a8e5542a97fbbbb480eb0557736d4f1817c0fd56262f442e4b3c2c68607baacdd38b1684def1af58a583bfb SHA512 6e0a3d5cd32c209fd71a2ce5f705a60db318c2133bcca07360a047a73892f642a1661c1f0fb90353fc43e75336dfc22909bf4969f1bd03324c9689344af08350
DIST pango-1.48.3.tar.xz 565956 BLAKE2B 6860ae9df2b8629bdd1c5acf03453e1c6d62d8fd100752a6d5762ab1e0f2b3cbefb55e0f3476e53209d07541e7f8dffc680507378e94ab39b49601582a35e9a7 SHA512 769ceec71c5d64c08b91a0d78c5e39f6599fa199ae3f9d6dc4b94e5898a41e7f4b3d3f9c16a92f03d0e558778a4ef5bbe2967eefef17173211d53ffdb3d72041
+DIST pango-1.48.4.tar.xz 1791332 BLAKE2B 281e1ba5b52b99c61bcd90dcefb3de64e45a6de0eec5a375e209cb4316562a03e81dea73e6fb8921a631ef854dca8b035e06b3cec7ff73bf8f0033151d2cd20b SHA512 ce754c5e915ed18ba0f0ec89d74a1094e5b235821514b247d16afba7b74ecf1d850ad2b7b7d0a43da83da126c74be1b2e4c4400dbcd447e388e75e6b3c8b4dbe
diff --git a/x11-libs/pango/pango-1.48.4.ebuild b/x11-libs/pango/pango-1.48.4.ebuild
new file mode 100644
index 000000000000..e35db085707d
--- /dev/null
+++ b/x11-libs/pango/pango-1.48.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils meson multilib-minimal toolchain-funcs xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+ FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# X USE flag is simply a stub until all revdeps have been adjusted to use X(+)
+IUSE="gtk-doc +introspection sysprof test +X"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/fribidi-0.19.7[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.12.92:1.0=[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0:=[glib(+),truetype(+),${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X,${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ sysprof? ( dev-util/sysprof-capture:4[${MULTILIB_USEDEP}] )
+"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.20
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ )
+"
+
+src_prepare() {
+ xdg_src_prepare
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature sysprof)
+ -Dcairo=enabled
+ -Dfontconfig=enabled
+ -Dfreetype=enabled
+ -Dgtk_doc="$(multilib_native_usex gtk-doc true false)"
+ -Dintrospection="$(multilib_native_usex introspection enabled disabled)"
+ -Dinstall-tests=false
+ -Dlibthai=disabled
+ -Dxft=enabled
+ )
+ meson_src_configure
+}
+
+muiltilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}