summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-16 00:04:13 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-16 00:04:13 +0100
commitd4d285c08c88a693ae1319a9e0f37f0fcbe18075 (patch)
tree779eb9f28cfb9f82d43006b6fc8c58cf1710ea49 /x11-libs
parentx11-misc/sddm: Remove vulnerable (diff)
downloadgentoo-d4d285c08c88a693ae1319a9e0f37f0fcbe18075.tar.gz
gentoo-d4d285c08c88a693ae1319a9e0f37f0fcbe18075.tar.bz2
gentoo-d4d285c08c88a693ae1319a9e0f37f0fcbe18075.zip
x11-libs/libdrm: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.67.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index d4c60d6dacbf..4f3db409d4b2 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1,3 +1,4 @@
DIST libdrm-2.4.59.tar.bz2 592722 SHA256 68d26e1fd85582f4243d66864f9b43ca4ee93662825de32b5506fc8e181ea41b SHA512 b9f61cfd47cf4a02c10e7fe79b0e9c5701383c76425cf4985a9b91d909f905334ca1ace7334aa0a4ab400694ad84a1a3bc1c3f29842d808026702b35fa9f87c3 WHIRLPOOL 6b0e1be70164db86152503e4b72373736f0462ff97ffac2c79a6c1fce83d658e6030d5435be5a61c1f6ca50728db4c7e3a5d8f5e48073fc74169696ff1b7c5be
DIST libdrm-2.4.65.tar.bz2 645877 SHA256 71960ac8bde7d710992b1bc8879935e8300a870c36bd06f22412d0447e3d96c4 SHA512 fabbb3ba163aa1307288472c11c6ce8f1e412cbd67ba3135a614f0e05bf4f881bf6ccc581e9cf05a7e2e965817bb71c0b5335263b5c0b0cb85829a0f29a6029d WHIRLPOOL b00d7aed0437ee0f64f60ed59becf41d165c101725cab700345203b2108a2adc9ed95d17acc0dff5706df86c87c13d058991417f42db40dfc523279cc5eb8547
DIST libdrm-2.4.66.tar.bz2 694574 SHA256 79cb8e988749794edfb2d777b298d5292eff353bbbb71ed813589e61d2bc2d76 SHA512 e0e3cea490389271690a79b5be8acd5e7c892a0646285617bd00d85f7c56ac163580c8c62d9fa79ed99e89468e35eaed6ac8be6ea870ce5ab09589f3e2d7f506 WHIRLPOOL 6f691c8f7444b70461896f2b91a5256c655124c12cb51b25163859db2f556692d182e43b79a851cbc8d565fde1cbe146133d177dbabe442289ab051170b6a695
+DIST libdrm-2.4.67.tar.bz2 689483 SHA256 ee5b71e1113be37544d0752681c12f040c01f782e2933df7d7bc21fd0d10cebe SHA512 3c48828b65b32a5e6a17b05b05d17ea02315b1c86c730d386d0680f2d8f312477cf5adc810a898a3734504c96ff376fc46b2d813b34cb8fe84a70b533c18ac2a WHIRLPOOL 134cdb80b035ba87027cbc074a05c1ed66eec4d462846f48b8c56e8eedd7b2b32dc9c6abeb01b0e9bf41f96364ab0bd59b881ef58651aded832b644faa2bd648
diff --git a/x11-libs/libdrm/libdrm-2.4.67.ebuild b/x11-libs/libdrm/libdrm-2.4.67.ebuild
new file mode 100644
index 000000000000..56690716affa
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.67.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="http://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+else
+ SRC_URI="http://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}