summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-03-04 18:28:44 -0800
committerMatt Turner <mattst88@gentoo.org>2017-03-04 18:37:56 -0800
commitdc334ab014eb05ab9b522b5e9933cb0aa9028852 (patch)
tree0f8226e422115d7816bbd055110089a9356a097c /x11-libs
parentx11-libs/libXvMC: Drop useless comment. (diff)
downloadgentoo-dc334ab014eb05ab9b522b5e9933cb0aa9028852.tar.gz
gentoo-dc334ab014eb05ab9b522b5e9933cb0aa9028852.tar.bz2
gentoo-dc334ab014eb05ab9b522b5e9933cb0aa9028852.zip
x11-libs/pixman: Drop old version 0.32.8.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pixman/Manifest1
-rw-r--r--x11-libs/pixman/files/pixman-0.32.8-clang.patch93
-rw-r--r--x11-libs/pixman/pixman-0.32.8.ebuild36
3 files changed, 0 insertions, 130 deletions
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index d5a8bfb9ab4f..2f4913eb3308 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1,2 +1 @@
-DIST pixman-0.32.8.tar.bz2 696038 SHA256 5c63dbb3523fc4d86ed4186677815918a941b7cb390d5eec4f55cb5d66b59fb1 SHA512 43924a92f0d3e03359bd74701cc2a27c000b24fc513e0f760389da7e6ee1acec666a734003ef193d45251cc9645c07caf91142c3ff9134b1429a38a9167332a2 WHIRLPOOL 0035c6e5713a79caeeb88e865204d708f9dc2fdc8881cc4468d64f1d31243b7399f1404d76c33f43b3c17daf46f7c5e33659a961f0847993cfd3d09015fa26eb
DIST pixman-0.34.0.tar.bz2 739656 SHA256 39ba3438f3d17c464b0cb8be006dacbca0ab5aee97ebde69fec7ecdbf85794a0 SHA512 755a3f5596e7bd9710abc8e5bfd341adaf2177f5b21f7aaae7f85b8fb57580ea48df586ad32bf6adef6ce0430e7cadaa57754a2fa466bc4b15bf70ee64cd1418 WHIRLPOOL c5aa0abc6f09b667cbb91b926536ffa9c2d88ef61b7d4d2377bd57dd6844689db61a9ef1ef6282878bbfec1068454d3d4f188b1ff269e86e3b77d95b261c4c06
diff --git a/x11-libs/pixman/files/pixman-0.32.8-clang.patch b/x11-libs/pixman/files/pixman-0.32.8-clang.patch
deleted file mode 100644
index d5319292fbd8..000000000000
--- a/x11-libs/pixman/files/pixman-0.32.8-clang.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From d24b415f3e2753a588759d028b811e1ce38fea6c Mon Sep 17 00:00:00 2001
-From: Andrea Canciani <ranma42@gmail.com>
-Date: Sun, 11 Oct 2015 09:45:57 +0200
-Subject: mmx: Improve detection of support for "K" constraint
-
-Older versions of clang emitted an error on the "K" constraint, but at
-least since version 3.7 it is supported. Just like gcc, this
-constraint is only allowed for constants, but apparently clang
-requires them to be known before inlining.
-
-Using the macro definition _mm_shuffle_pi16(A, N) ensures that the "K"
-constraint is always applied to a literal constant, independently from
-the compiler optimizations and allows building pixman-mmx on modern
-clang.
-
-Reviewed-by: Matt Turner <mattst88@gmail.com>
-Signed-off-by: Andrea Canciani <ranma42@gmail.com>
-
-diff --git a/configure.ac b/configure.ac
-index 2178126..3a66909 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -347,15 +347,27 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
- #error "Need GCC >= 3.4 for MMX intrinsics"
- #endif
- #include <mmintrin.h>
-+#include <stdint.h>
-+
-+/* Check support for block expressions */
-+#define _mm_shuffle_pi16(A, N) \
-+ ({ \
-+ __m64 ret; \
-+ \
-+ /* Some versions of clang will choke on K */ \
-+ asm ("pshufw %2, %1, %0\n\t" \
-+ : "=y" (ret) \
-+ : "y" (A), "K" ((const int8_t)N) \
-+ ); \
-+ \
-+ ret; \
-+ })
-+
- int main () {
- __m64 v = _mm_cvtsi32_si64 (1);
- __m64 w;
-
-- /* Some versions of clang will choke on K */
-- asm ("pshufw %2, %1, %0\n\t"
-- : "=y" (w)
-- : "y" (v), "K" (5)
-- );
-+ w = _mm_shuffle_pi16(v, 5);
-
- /* Some versions of clang will choke on this */
- asm ("pmulhuw %1, %0\n\t"
-diff --git a/pixman/pixman-mmx.c b/pixman/pixman-mmx.c
-index 05c48a4..dec3974 100644
---- a/pixman/pixman-mmx.c
-+++ b/pixman/pixman-mmx.c
-@@ -89,21 +89,7 @@ _mm_mulhi_pu16 (__m64 __A, __m64 __B)
- return __A;
- }
-
--# ifdef __OPTIMIZE__
--extern __inline __m64 __attribute__((__gnu_inline__, __always_inline__, __artificial__))
--_mm_shuffle_pi16 (__m64 __A, int8_t const __N)
--{
-- __m64 ret;
--
-- asm ("pshufw %2, %1, %0\n\t"
-- : "=y" (ret)
-- : "y" (__A), "K" (__N)
-- );
--
-- return ret;
--}
--# else
--# define _mm_shuffle_pi16(A, N) \
-+# define _mm_shuffle_pi16(A, N) \
- ({ \
- __m64 ret; \
- \
-@@ -114,7 +100,6 @@ _mm_shuffle_pi16 (__m64 __A, int8_t const __N)
- \
- ret; \
- })
--# endif
- # endif
- #endif
-
---
-cgit v0.10.2
-
diff --git a/x11-libs/pixman/pixman-0.32.8.ebuild b/x11-libs/pixman/pixman-0.32.8.ebuild
deleted file mode 100644
index c82debe0530d..000000000000
--- a/x11-libs/pixman/pixman-0.32.8.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-XORG_EAUTORECONF=yes
-XORG_MULTILIB=yes
-inherit xorg-2 toolchain-funcs versionator
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
-DESCRIPTION="Low-level pixel manipulation routines"
-
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="altivec iwmmxt loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
-RDEPEND="abi_x86_32? (
- !<=app-emulation/emul-linux-x86-gtklibs-20131008
- !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
- )"
-
-PATCHES=(
- "${FILESDIR}/${P}-clang.patch"
-)
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable cpu_flags_x86_mmxext mmx)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable cpu_flags_x86_ssse3 ssse3)
- $(use_enable altivec vmx)
- $(use_enable neon arm-neon)
- $(use_enable iwmmxt arm-iwmmxt)
- $(use_enable loongson2f loongson-mmi)
- --disable-gtk
- --disable-libpng
- )
- xorg-2_src_configure
-}