summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-11-08 14:30:10 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-08 15:11:26 +0100
commitfe1f5395e5b124a095d4de25fdac7862da4e0e81 (patch)
tree470caa61be99116ae8176bfdfa5f685e4e6b171a /x11-libs
parentwww-plugins/adobe-flash: Version bump (maybe bug #599204). (diff)
downloadgentoo-fe1f5395e5b124a095d4de25fdac7862da4e0e81.tar.gz
gentoo-fe1f5395e5b124a095d4de25fdac7862da4e0e81.tar.bz2
gentoo-fe1f5395e5b124a095d4de25fdac7862da4e0e81.zip
x11-libs/vte: add vte-0.46.1.ebuild
Copied from vte-0.46.0.ebuild and checked https://git.gnome.org/browse/vte/diff/?id=0.46.1&&id2=0.46.0 for dependency changes Closes: https://github.com/gentoo/gentoo/pull/2779 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/Manifest1
-rw-r--r--x11-libs/vte/vte-0.46.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index bb876b25f00f..db64defb90dc 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -4,3 +4,4 @@ DIST vte-0.40.2.tar.xz 923852 SHA256 9b68fbc16b27f2d79e6271f2b0708808594ac5acf97
DIST vte-0.42.5.tar.xz 928136 SHA256 53cc15c5315d73b69f7848e07a5c512cd40b7caf0323e3d0e0d75d7ae65deee7 SHA512 7e8b0730dc9f281c928c50225bb8e57b365408153aed8e7efe8c57f33124e2c64c62713ed62991db41f0df4cbfd3e4c9a49a62c0330b62cbe2fcf1ea8eae7acc WHIRLPOOL 901bacd032078299a7f8b93f63f45b8ff1b9e3ac0cc6dc9d5ef8ad63fc4399d30b32ba3a2022ee9db2fcfa400a731b2a0b4ed40add4934e9cd2de0ce1ac56817
DIST vte-0.44.2.tar.xz 974596 SHA256 a1ea594814bb136a3a9a6c7656b46240571f6a198825c1111007fe99194b0949 SHA512 98db3c1528d5f458164e2d30056cd816e5943d9c569551878119e79d4fbca1865e52667393bf298f32fd54710d1b268a5aac125222ecb29ce854522be3776356 WHIRLPOOL 62830dc20a3aa29f4c13b3370d960f5522bb42231b68f426b2b662a40c4c8265f9d8a76c4e598cdfd5c8d8c5f712d3d9828f5f2ed5e24182f9be8697debe2ca6
DIST vte-0.46.0.tar.xz 992884 SHA256 5f7122e7860eb2470d310fc63df91d3ee32bab233729c2dc181a0cbc9b3249d7 SHA512 543cdba5c51c5384e54fc372924c2667ded952cbc8ffafb7ff62f8643c6a7e2440439109eb12378ed70b0e0a256d3ef97d6da004dd8088d36bccdd7fa16593f9 WHIRLPOOL 931190c55e52a2f3eca853f8d466acd4361dc0736f36b624ed1e8431f48158e618ddff0265bd8aff5154afdf1e1eef2652c58051d7839dd50071d606f4fc9cad
+DIST vte-0.46.1.tar.xz 989164 SHA256 8800cf8bc259704a12ad1853fb0eb43bfe3857af15242e6fb9f2c3fd95b3f5c6 SHA512 04b3f8ce922c4326d92bef605a0dbe195764946cd5f1acf28fd6d69c0cdb2ee661cc7e424436c72380da5d0250790ae658ac49d761b567dea88d92157285889d WHIRLPOOL 7947982c2e9eba1481f302da8bf3433156490537c9e7ab1ef8da8d399b3dccec0911253b8973712be77fa89f7eb9451e09b65ffd6cc2ccc6e2bea9fb9f2997f8
diff --git a/x11-libs/vte/vte-0.46.1.ebuild b/x11-libs/vte/vte-0.46.1.ebuild
new file mode 100644
index 000000000000..d3b877ab97e4
--- /dev/null
+++ b/x11-libs/vte/vte-0.46.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+
+LICENSE="LGPL-2+"
+SLOT="2.91"
+IUSE="+crypt debug glade +introspection vala"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=dev-libs/libpcre2-10.21
+ >=x11-libs/gtk+-3.8:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+
+ crypt? ( >=net-libs/gnutls-3.2.7 )
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${RDEPEND}
+ !x11-libs/vte:2.90[glade]
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+
+ # build fails because of -Werror with gcc-5.x
+ sed -e 's#-Werror=format=2#-Wformat=2#' -i configure || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ myconf="${myconf} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ gnome2_src_configure \
+ --disable-test-application \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_with crypt gnutls) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_install() {
+ gnome2_src_install
+ mv "${D}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}