summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/3ddesktop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/3ddesktop')
-rw-r--r--x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild58
-rw-r--r--x11-misc/3ddesktop/Manifest1
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch13
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch14
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch23
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch12
-rw-r--r--x11-misc/3ddesktop/metadata.xml13
7 files changed, 134 insertions, 0 deletions
diff --git a/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild b/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild
new file mode 100644
index 000000000000..68896485ba48
--- /dev/null
+++ b/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="OpenGL virtual desktop switching"
+HOMEPAGE="http://desk3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/desk3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ >=media-libs/freetype-2
+ media-libs/freeglut
+ media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto
+"
+
+DOCS=( AUTHORS TODO ChangeLog README README.windowmanagers )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-missing-include.patch \
+ "${FILESDIR}"/${P}-gl_init.patch
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ echo
+ elog "This ebuild installed a configuration file called /etc/3ddesktop.conf"
+ elog "The default configuration makes a screenshot of the virtual desktops"
+ elog "every X seconds. This is non-optimal behavior."
+ elog
+ elog "To enable a more intelligent way of updating the virtual desktops,"
+ elog "execute the following:"
+ elog
+ elog " echo \"AutoAcquire 0\" >> /etc/3ddesktop.conf"
+ elog
+ elog "This will cause 3ddesktop to update the virtual desktop snapshots"
+ elog "only when a 3d desktop switch is required."
+}
diff --git a/x11-misc/3ddesktop/Manifest b/x11-misc/3ddesktop/Manifest
new file mode 100644
index 000000000000..3c778c2be7e1
--- /dev/null
+++ b/x11-misc/3ddesktop/Manifest
@@ -0,0 +1 @@
+DIST 3ddesktop-0.2.9.tar.gz 182278 SHA256 8fde969c1aec60685e0a74d2ebcfa1ef570df454288d5774646e2b291515e8c5 SHA512 87de83561bc1614e4dde623197b04e482e04ad363ba88adf4e4e9950a942a5725d2a7199406949981c1a4aeba5d71fb9a1693f99aefa21ed7b83e083bb902686 WHIRLPOOL 5238f9c99b1df49cab181e0d872c6af0d54b8fc126801c9d7a0b145729e7921cb5db82d734498506af74a0dcc2a7fe51009bfbe6a06b018754ed5980aa32560f
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch
new file mode 100644
index 000000000000..2534535dee1f
--- /dev/null
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/206817
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -37,7 +37,7 @@
+ camera.cpp \
+ config.cpp
+
+-3ddeskd_LDFLAGS = $(imlib2_libs) @GL_LIBS@
++3ddeskd_LDADD = $(imlib2_libs) @GL_LIBS@
+
+ noinst_HEADERS = 3ddesk.h \
+ arrange.hpp \
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch
new file mode 100644
index 000000000000..a67753fcee39
--- /dev/null
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/118458
+
+--- a/event.hpp
++++ b/event.hpp
+@@ -74,7 +74,7 @@
+ list<Event *>::iterator k;
+ for (k = events.begin(); k != events.end(); ++k) {
+ Event *e = *k;
+- printf(":: Event %d 0x%x\n", e->type, (unsigned int)(e->function));
++ printf(":: Event %d %p\n", e->type, e->function);
+ }
+ }
+
+
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch
new file mode 100644
index 000000000000..d817cea54ece
--- /dev/null
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/123762
+
+--- a/3ddeskd.cpp
++++ b/3ddeskd.cpp
+@@ -2411,15 +2411,15 @@
+
+ // initialize opengl
+
+- // our own init function.
+- gl_init();
+-
+ GLWin.open_display();
+
+
+ GLWin.create_GL_window("Enhanced 3-dimensional workspace visualization magic machine",
+ cfg->options->do_fullscreen);
+
++ // our own init function.
++ gl_init();
++
+ cfg->texture_size = GLWin.get_best_texture_size(cfg->texture_size);
+
+ // Loads up the correct perspective matrix
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch
new file mode 100644
index 000000000000..328cbcad6d29
--- /dev/null
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/228217
+
+--- a/config.hpp
++++ b/config.hpp
+@@ -24,6 +24,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ #include <errno.h>
+ #include <unistd.h>
diff --git a/x11-misc/3ddesktop/metadata.xml b/x11-misc/3ddesktop/metadata.xml
new file mode 100644
index 000000000000..a31c49d0edc4
--- /dev/null
+++ b/x11-misc/3ddesktop/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription>
+3d Destkop is an OpenGL program for switching virtual desktops in a seamless
+3-dimensional manner. The current desktop is mapped into a 3D space where you
+may choose other screens. Several different visualization modes are available.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">desk3d</remote-id>
+ </upstream>
+</pkgmetadata>