summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-18 18:40:43 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-18 18:54:21 -0400
commit35c573aa886164ec955f29bfeb892c99a6bd5ace (patch)
tree30dbdddc9a76f40368a31366314a790c95d15f6d /x11-misc/alacarte
parentdev-vcs/gitolite: add 3.6.13 (diff)
downloadgentoo-35c573aa886164ec955f29bfeb892c99a6bd5ace.tar.gz
gentoo-35c573aa886164ec955f29bfeb892c99a6bd5ace.tar.bz2
gentoo-35c573aa886164ec955f29bfeb892c99a6bd5ace.zip
x11-misc/alacarte: Version bump to 3.44.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc/alacarte')
-rw-r--r--x11-misc/alacarte/Manifest1
-rw-r--r--x11-misc/alacarte/alacarte-3.44.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
index 635e21745e23..12cd113b92b8 100644
--- a/x11-misc/alacarte/Manifest
+++ b/x11-misc/alacarte/Manifest
@@ -1 +1,2 @@
DIST alacarte-3.44.2.tar.xz 253580 BLAKE2B 206eea28b50ef6d0cf228031ff72c16c6ebd130dfa623b96eb727ef62aad3db0003f3a97bc188f4b8a0e9d18cc184a9230fb332131d37afb0abe71dc3d13ee1e SHA512 b62c15ca37717e988b1d64f0ab565970ae15a4bc11a3f31da8574a0b4f10a9cf8b94d0a85be34d871c106ab34c63b2dfbf535b46eb630829e73c14023b99053e
+DIST alacarte-3.44.3.tar.xz 248692 BLAKE2B bb418aebb595935028b5bec9b08b516d90c6488ef4201b184f51420c5918f986d3dda20c2eb8d7666bb3fa7d4249af59afb00777d93d5715ef54d604943ef952 SHA512 2e10b79527b3343379f7b58efa9ae3a4428d05fee11279ae95e0514712ec97489b1152cabcdf2abcaa3d1e396218e2708b0c47e20e6e55e2d34b848e7e2d9ee2
diff --git a/x11-misc/alacarte/alacarte-3.44.3.ebuild b/x11-misc/alacarte/alacarte-3.44.3.ebuild
new file mode 100644
index 000000000000..e37452553a19
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.44.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}