summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/alacarte
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/alacarte')
-rw-r--r--x11-misc/alacarte/Manifest2
-rw-r--r--x11-misc/alacarte/alacarte-3.10.0.ebuild62
-rw-r--r--x11-misc/alacarte/alacarte-3.11.91.ebuild62
-rw-r--r--x11-misc/alacarte/metadata.xml5
4 files changed, 131 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
new file mode 100644
index 000000000000..6fcf6e22fb17
--- /dev/null
+++ b/x11-misc/alacarte/Manifest
@@ -0,0 +1,2 @@
+DIST alacarte-3.10.0.tar.xz 181576 SHA256 bdc91981859a5076ae38a213892074e1263629835702920d47f6ee2bb76179f1 SHA512 7ac46fe754c8ddb83856440ebd1c383ef8ec6f8b9601774442613e1a4ccbbc919eed221b4d4555b9dba3af78dbd985fed4320fbeada4eb68f7c088ebee01f564 WHIRLPOOL 231b64749c033c3e45433d743179437f2f41e9c3cfa99beea99e9040b08ed9eb2d06e25e9d7212d41d5a29a32d4f63fc21e6da091a199c4a180505c13a6b04b7
+DIST alacarte-3.11.91.tar.xz 199128 SHA256 d77294f25ac9e4f293530080578d83dc8e014d5b7c6c01d6f9a7f1715719a384 SHA512 b4b5ead4ba0b9742ea0530ecb5362afa970125d29750aaf147be6fd477f238b9c360307ce1df2a56330a69cd9c849a0dde4be44b36bf55377f42e30429411935 WHIRLPOOL 6a6e2f47486c714dd1d35b6814f6a5dabd79799d9d101d7d2e8e74b2cef0d9f028bab104213574fb067d2419f82af3f4c79ad6d59b457237837ce5c65d764b02
diff --git a/x11-misc/alacarte/alacarte-3.10.0.ebuild b/x11-misc/alacarte/alacarte-3.10.0.ebuild
new file mode 100644
index 000000000000..09265d02274c
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.10.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+# FIXME: support python3 but installs in a weird location
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://git.gnome.org/browse/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i alacarte || die
+ python_doscript alacarte
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/x11-misc/alacarte/alacarte-3.11.91.ebuild b/x11-misc/alacarte/alacarte-3.11.91.ebuild
new file mode 100644
index 000000000000..2d689edd3f37
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.11.91.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+# FIXME: support python3 but installs in a weird location
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://git.gnome.org/browse/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i alacarte || die
+ python_doscript alacarte
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/x11-misc/alacarte/metadata.xml b/x11-misc/alacarte/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/x11-misc/alacarte/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>