summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/apwal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/apwal')
-rw-r--r--x11-misc/apwal/Manifest1
-rw-r--r--x11-misc/apwal/apwal-0.4.5-r1.ebuild38
-rw-r--r--x11-misc/apwal/files/apwal-0.4.5-makefile.patch67
-rw-r--r--x11-misc/apwal/metadata.xml5
4 files changed, 111 insertions, 0 deletions
diff --git a/x11-misc/apwal/Manifest b/x11-misc/apwal/Manifest
new file mode 100644
index 000000000000..f50da71fd193
--- /dev/null
+++ b/x11-misc/apwal/Manifest
@@ -0,0 +1 @@
+DIST apwal-0.4.5.tar.gz 73999 SHA256 0de64be9b40d853ef1efe69faf99e3e7b9c3b756575ed9f40e16aa4fe74844f3
diff --git a/x11-misc/apwal/apwal-0.4.5-r1.ebuild b/x11-misc/apwal/apwal-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..3e59f37bc418
--- /dev/null
+++ b/x11-misc/apwal/apwal-0.4.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A simple application launcher and combined editor"
+HOMEPAGE="http://apwal.free.fr/"
+SRC_URI="http://apwal.free.fr/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf
+ dev-libs/libxml2
+ dev-libs/glib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ABOUT Changelog FAQ README || die
+}
diff --git a/x11-misc/apwal/files/apwal-0.4.5-makefile.patch b/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
new file mode 100644
index 000000000000..462ba882d8e3
--- /dev/null
+++ b/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
@@ -0,0 +1,67 @@
+* Fix parallel build
+* Respect CC, CFLAGS, LDFLAGS #333969
+* don't strip binaries
+* fix install paths
+
+--- Makefile
++++ Makefile
+@@ -1,11 +1,8 @@
+
+ include Makefile.inc
+
+-all:
+- (cd src && $(MAKE) $@)
+-
+-install:
+- (cd src && $(MAKE) $@)
++all install:
++ $(MAKE) -C src $@
+
+ clean:
+ (cd src && $(MAKE) $@)
+--- src/Makefile
++++ src/Makefile
+@@ -5,8 +5,8 @@
+ CFLAGS=-g -Wall -Werror `pkg-config --cflags gtk+-2.0 gthread-2.0` -DGTK_DISABLE_DEPRECATED -DAPWAL_DEBUG
+ LDFLAGS=`pkg-config --libs gtk+-2.0 gthread-2.0` `xml2-config --libs`
+ else
+-CFLAGS=-O2 `pkg-config --cflags gtk+-2.0 gthread-2.0`
+-LDFLAGS=-O2 `pkg-config --libs gtk+-2.0 gthread-2.0` `xml2-config --libs`
++CPPFLAGS=`pkg-config --cflags gtk+-2.0 gthread-2.0`
++LIBS=`pkg-config --libs gtk+-2.0 gthread-2.0` `xml2-config --libs`
+ endif
+
+ OBJS=main.o app.o launcher.o editor.o property.o \
+@@ -24,25 +24,24 @@
+ ifdef APWAL_DEBUG
+ all: checktraceformat apwal tags
+ apwal: $(OBJS)
+- gcc -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+ else
+ all: apwal
+ apwal: $(OBJS)
+- gcc -o $@ $^ $(LDFLAGS)
+- strip $@
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+ endif
+
+ install: all
+- cp apwal /usr/local/bin/
+- ln -sf /usr/local/bin/apwal /usr/local/bin/apwal-editor
++ install -D -m 755 apwal $(DESTDIR)/usr/bin/apwal
++ ln -sf apwal $(DESTDIR)/usr/bin/apwal-editor
+
+ .c.o: $(INCS)
+- gcc -c $< -o $*.o $(CFLAGS)
++ $(CC) -c $(CPPFLAGS) $(CFLAGS) $< -o $*.o
+
+ xmlrc.o: xmlrc.c $(INCS)
+- gcc -c $< -o $*.o $(CFLAGS) `xml2-config --cflags`
++ $(CC) $(CPPFLAGS) $(CFLAGS) `xml2-config --cflags` -c $< -o $*.o
+ about.o: about.c $(INCS) ../Makefile.inc
+- gcc -c $< -o $*.o $(CFLAGS) -DAPWAL_VERSION=\"$(VERS)\"
++ $(CC) $(CPPFLAGS) -DAPWAL_VERSION=\"$(VERS)\" $(CFLAGS) -c $< -o $*.o
+
+ gtkstuff.o: pixbufinline.inc
+ xmlrc.o: xmlrcinline.inc
diff --git a/x11-misc/apwal/metadata.xml b/x11-misc/apwal/metadata.xml
new file mode 100644
index 000000000000..40838bc36783
--- /dev/null
+++ b/x11-misc/apwal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+</pkgmetadata>