summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-13 15:46:22 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-14 22:33:18 +0200
commite463984e8656ef26d3a10477a2daac9be3b6942b (patch)
treee9550e065e795170b3628097aed93107d3ff5257 /x11-misc/cbatticon/cbatticon-1.5.0.ebuild
parentnet-fs/openafs{,-kernel}: Stabilize amd64/x86 as per Bug: 556354 (diff)
downloadgentoo-e463984e8656ef26d3a10477a2daac9be3b6942b.tar.gz
gentoo-e463984e8656ef26d3a10477a2daac9be3b6942b.tar.bz2
gentoo-e463984e8656ef26d3a10477a2daac9be3b6942b.zip
x11-misc/cbatticon: version bump to 1.5.0
Diffstat (limited to 'x11-misc/cbatticon/cbatticon-1.5.0.ebuild')
-rw-r--r--x11-misc/cbatticon/cbatticon-1.5.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/cbatticon/cbatticon-1.5.0.ebuild b/x11-misc/cbatticon/cbatticon-1.5.0.ebuild
new file mode 100644
index 000000000000..01840f093d8e
--- /dev/null
+++ b/x11-misc/cbatticon/cbatticon-1.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A lightweight and fast battery icon that sits in your system tray"
+HOMEPAGE="https://github.com/ColinJones/cbatticon"
+SRC_URI="https://github.com/ColinJones/cbatticon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC
+ emake \
+ $(usex libnotify WITH_NOTIFY=1 WITH_NOTIFY=0) \
+ V=1 \
+ VERSION="${PF}" \
+ WITH_GTK3=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" V=1 VERSION="${PF}" install
+}