summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-04-07 13:13:03 +0200
committerJeroen Roovers <jer@gentoo.org>2016-04-07 13:40:48 +0200
commitef3934030c8a580a921c6ea82282317835291999 (patch)
tree36bd42ee7055ede05e10e62600a16230e0a7ed1f /x11-misc/devilspie2/devilspie2-0.41.ebuild
parentdev-libs/protobuf-c: Removed old. (diff)
downloadgentoo-ef3934030c8a580a921c6ea82282317835291999.tar.gz
gentoo-ef3934030c8a580a921c6ea82282317835291999.tar.bz2
gentoo-ef3934030c8a580a921c6ea82282317835291999.zip
x11-misc/devilspie2: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-misc/devilspie2/devilspie2-0.41.ebuild')
-rw-r--r--x11-misc/devilspie2/devilspie2-0.41.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/devilspie2/devilspie2-0.41.ebuild b/x11-misc/devilspie2/devilspie2-0.41.ebuild
new file mode 100644
index 000000000000..8be06c95f063
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.41.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# check locales on version bump!
+PLOCALES="fi fr ja nl pt_BR ru sv"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://gusnan.se/devilspie2"
+SRC_URI="http://download.savannah.gnu.org/releases/devilspie2/devilspie2_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5:0
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default directory for scripts is ~/.config/devilspie2/"
+}