summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-05 13:41:59 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-05 20:06:51 +0100
commitf162e6dab285aefc570d27f9b0f075065bc2309b (patch)
treef459101e78d3c5c6f1a261c81508e41aac66c531 /x11-misc/driconf/driconf-0.9.1-r2.ebuild
parentdev-libs/cryptlib: fixups (diff)
downloadgentoo-f162e6dab285aefc570d27f9b0f075065bc2309b.tar.gz
gentoo-f162e6dab285aefc570d27f9b0f075065bc2309b.tar.bz2
gentoo-f162e6dab285aefc570d27f9b0f075065bc2309b.zip
x11-misc/driconf: Bump eapi, use newer python eclass, fix issues
Fixes: https://bugs.gentoo.org/352016 drop-old-tooltips patch is made by Rafał Mużyło, see bug #352016 Also fixes following QA issuses: * /usr/share/applications/driconf.desktop: error: value "GNOME;Application;Settings;AdvancedSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "AdvancedSettings"; values extending the format should start with "X-" * /usr/share/applications/driconf.desktop: warning: value "GNOME;Application;Settings;AdvancedSettings;" for key "Categories" in group "Desktop Entry" contains a deprecated value "Application" Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3826
Diffstat (limited to 'x11-misc/driconf/driconf-0.9.1-r2.ebuild')
-rw-r--r--x11-misc/driconf/driconf-0.9.1-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/driconf/driconf-0.9.1-r2.ebuild b/x11-misc/driconf/driconf-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..c3b79c2128c8
--- /dev/null
+++ b/x11-misc/driconf/driconf-0.9.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="driconf is a GTK+2 GUI configurator for DRI"
+HOMEPAGE="https://dri.freedesktop.org/wiki/DriConf"
+SRC_URI="https://freedesktop.org/~fxkuehl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ x11-apps/xdriinfo"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG COPYING PKG-INFO README TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-glxinfo-unicode.patch
+ "${FILESDIR}"/${P}-update-toolbar-methods.patch
+ "${FILESDIR}"/${P}-driconf_simpleui.py.patch
+ "${FILESDIR}"/${P}-desktop-menu.patch
+ "${FILESDIR}"/${P}-drop-old-tooltips.patch
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Fix install locations which breaks location policy - Josh_B
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ driconf \
+ driconf.desktop \
+ driconf.py \
+ setup.cfg \
+ setup.py \
+ || die "Sed failed!"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu driconf.desktop
+}