summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/driconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/driconf')
-rw-r--r--x11-misc/driconf/Manifest1
-rw-r--r--x11-misc/driconf/driconf-0.9.1-r1.ebuild59
-rw-r--r--x11-misc/driconf/files/driconf-0.9.1-driconf_simpleui.py.patch16
-rw-r--r--x11-misc/driconf/files/driconf-0.9.1-glxinfo-unicode.patch22
-rw-r--r--x11-misc/driconf/files/driconf-0.9.1-update-toolbar-methods.patch108
-rw-r--r--x11-misc/driconf/metadata.xml5
6 files changed, 211 insertions, 0 deletions
diff --git a/x11-misc/driconf/Manifest b/x11-misc/driconf/Manifest
new file mode 100644
index 000000000000..2fc475ee7c3d
--- /dev/null
+++ b/x11-misc/driconf/Manifest
@@ -0,0 +1 @@
+DIST driconf-0.9.1.tar.gz 112529 SHA256 4849a43f6324498e943c03777bce571229b5446985b1cec596b365505e76f73f
diff --git a/x11-misc/driconf/driconf-0.9.1-r1.ebuild b/x11-misc/driconf/driconf-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..300bbc62de7b
--- /dev/null
+++ b/x11-misc/driconf/driconf-0.9.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="xml"
+
+inherit distutils eutils
+
+DESCRIPTION="driconf is a GTK+2 GUI configurator for DRI"
+HOMEPAGE="http://dri.freedesktop.org/wiki/DriConf"
+SRC_URI="http://freedesktop.org/~fxkuehl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4:2
+ >=dev-python/pygtk-2.4:2
+ x11-apps/xdriinfo"
+DEPEND="${RDEPEND}"
+
+DOCS="CHANGELOG COPYING PKG-INFO README TODO"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glxinfo-unicode.patch \
+ "${FILESDIR}"/${P}-update-toolbar-methods.patch \
+ "${FILESDIR}"/${P}-driconf_simpleui.py.patch
+
+ # Fix install locations which breaks location policy - Josh_B
+ sed -i \
+ -e 's-/usr/local-/usr-g' \
+ driconf \
+ driconf.desktop \
+ driconf.py \
+ setup.cfg \
+ setup.py \
+ || die "Sed failed!"
+}
+
+src_install() {
+ distutils_src_install
+ domenu driconf.desktop
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/lib/driconf
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib/driconf
+}
diff --git a/x11-misc/driconf/files/driconf-0.9.1-driconf_simpleui.py.patch b/x11-misc/driconf/files/driconf-0.9.1-driconf_simpleui.py.patch
new file mode 100644
index 000000000000..fb661c819be2
--- /dev/null
+++ b/x11-misc/driconf/files/driconf-0.9.1-driconf_simpleui.py.patch
@@ -0,0 +1,16 @@
+http://cvs.fedoraproject.org/viewvc/rpms/driconf/devel/
+
+--- driconf_simpleui.py
++++ driconf_simpleui.py
+@@ -266,8 +266,8 @@
+ j = i
+ break
+ i = i - 1
+- if i < chars/3:
+- i = chars
++ else:
++ i = j = chars
+ head, tail = head + tail[:i] + '\n', tail[j:]
+ return head
+
+
diff --git a/x11-misc/driconf/files/driconf-0.9.1-glxinfo-unicode.patch b/x11-misc/driconf/files/driconf-0.9.1-glxinfo-unicode.patch
new file mode 100644
index 000000000000..df4155025255
--- /dev/null
+++ b/x11-misc/driconf/files/driconf-0.9.1-glxinfo-unicode.patch
@@ -0,0 +1,22 @@
+http://cvs.fedoraproject.org/viewvc/rpms/driconf/devel/
+
+--- driconf_simpleui.py
++++ driconf_simpleui.py
+@@ -450,11 +450,13 @@ class MainWindow (gtk.Window):
+ else:
+ screen = self.screens[0]
+ if screen.glxInfo:
+- text = "%s (%s)" % (
+- screen.glxInfo.renderer, screen.glxInfo.vendor)
++ text = u"%s (%s)" % (
++ unicode(screen.glxInfo.renderer, "utf-8", "replace"),
++ unicode(screen.glxInfo.vendor, "utf-8", "replace"))
+ else:
+- text = _("Screen") + " %d: %s" % (
+- screen.num, screen.driver.name.capitalize())
++ text = _(u"Screen") + u" %d: %s" % (screen.num,
++ unicode(screen.driver.name, "utf-8",
++ "replace").capitalize())
+ deviceHBox = gtk.HBox()
+ deviceLabel = gtk.Label()
+ deviceLabel.set_justify(gtk.JUSTIFY_LEFT)
diff --git a/x11-misc/driconf/files/driconf-0.9.1-update-toolbar-methods.patch b/x11-misc/driconf/files/driconf-0.9.1-update-toolbar-methods.patch
new file mode 100644
index 000000000000..d6ce7e5c73e9
--- /dev/null
+++ b/x11-misc/driconf/files/driconf-0.9.1-update-toolbar-methods.patch
@@ -0,0 +1,108 @@
+http://cvs.fedoraproject.org/viewvc/rpms/driconf/devel/
+
+--- driconf_complexui.py
++++ driconf_complexui.py
+@@ -838,42 +838,73 @@ class MainWindow (gtk.Window):
+ self.paned.show()
+ self.toolbar = gtk.Toolbar ()
+ iconSize = self.toolbar.get_icon_size()
+- self.saveButton = self.toolbar.insert_stock (
+- "gtk-save", _("Save selected configuration file"),
+- "priv", self.configTree.saveConfig, None, -1)
+- self.reloadButton = self.toolbar.insert_stock (
+- "gtk-revert-to-saved", _("Reload selected configuration file"),
+- "priv", self.configTree.reloadConfig, None, -1)
+- self.toolbar.append_space()
+- self.newButton = self.toolbar.insert_stock (
+- "gtk-new", _("Create a new device or application"),
+- "priv", self.configTree.newItem, None, -1)
+- self.removeButton = self.toolbar.insert_stock (
+- "gtk-delete", _("Remove selected device or application"),
+- "priv", self.configTree.removeItem, None, -1)
+- self.upButton = self.toolbar.insert_stock (
+- "gtk-go-up", _("Move selected item up"),
+- "priv", self.configTree.moveUp, None, -1)
+- self.downButton = self.toolbar.insert_stock (
+- "gtk-go-down", _("Move selected item down"),
+- "priv", self.configTree.moveDown, None, -1)
+- self.propertiesButton = self.toolbar.insert_stock (
+- "gtk-properties", _("Properties of selected device or application"),
+- "priv", self.configTree.properties, None, -1)
+- self.toolbar.append_space()
++
++ self.saveButton = gtk.ToolButton("gtk-save")
++ self.saveButton.set_tooltip_text(_("Save selected configuration file"))
++ self.saveButton.connect("clicked", self.configTree.saveConfig)
++ self.saveButton.show()
++ self.toolbar.insert(self.saveButton, -1)
++ self.reloadButton = gtk.ToolButton("gtk-revert-to-saved")
++ self.reloadButton.set_tooltip_text(_("Reload selected configuration file"))
++ self.reloadButton.connect("clicked", self.configTree.reloadConfig)
++ self.reloadButton.show()
++ self.toolbar.insert(self.reloadButton, -1)
++
++ separator = gtk.SeparatorToolItem()
++ separator.show()
++ self.toolbar.insert(separator, -1)
++
++ self.newButton = gtk.ToolButton("gtk-new")
++ self.newButton.set_tooltip_text(_("Create a new device or application"))
++ self.newButton.connect("clicked", self.configTree.newItem)
++ self.newButton.show()
++ self.toolbar.insert(self.newButton, -1)
++ self.removeButton = gtk.ToolButton("gtk-delete")
++ self.removeButton.set_tooltip_text(_("Remove selected device or application"))
++ self.removeButton.connect("clicked", self.configTree.removeItem)
++ self.removeButton.show()
++ self.toolbar.insert(self.removeButton, -1)
++ self.upButton = gtk.ToolButton("gtk-go-up")
++ self.upButton.set_tooltip_text(_("Move selected item up"))
++ self.upButton.connect("clicked", self.configTree.moveUp)
++ self.upButton.show()
++ self.toolbar.insert(self.upButton, -1)
++ self.downButton = gtk.ToolButton("gtk-go-down")
++ self.downButton.set_tooltip_text(_("Move selected item down"))
++ self.downButton.connect("clicked", self.configTree.moveDown)
++ self.downButton.show()
++ self.toolbar.insert(self.downButton, -1)
++ self.propertiesButton = gtk.ToolButton("gtk-properties")
++ self.propertiesButton.set_tooltip_text(_("Properties of selected device or application"))
++ self.propertiesButton.connect("clicked", self.configTree.properties)
++ self.propertiesButton.show()
++ self.toolbar.insert(self.propertiesButton, -1)
++
++ separator = gtk.SeparatorToolItem()
++ separator.show()
++ self.toolbar.insert(separator, -1)
++
+ # The gtk-about stock item is available with gtk >= 2.6.
+ # It's definitely not available with gtk 2.2. Not sure about 2.4.
+ if gtk.gtk_version[0] == 2 and gtk.gtk_version[1] < 6:
+ aboutStock = "gtk-dialog-info"
+ else:
+ aboutStock = "gtk-about"
+- self.aboutButton = self.toolbar.insert_stock (
+- aboutStock, _("About DRIconf"), "priv",
+- self.aboutHandler, None, -1)
+- self.toolbar.append_space()
+- self.exitButton = self.toolbar.insert_stock (
+- "gtk-quit", _("Exit DRIconf"), "priv",
+- self.exitHandler, None, -1)
++ self.aboutButton = gtk.ToolButton(aboutStock)
++ self.aboutButton.set_tooltip_text(_("About DRIconf"))
++ self.aboutButton.connect("clicked", self.aboutHandler)
++ self.aboutButton.show()
++ self.toolbar.insert(self.aboutButton, -1)
++
++ separator = gtk.SeparatorToolItem()
++ separator.show()
++ self.toolbar.insert(separator, -1)
++
++ self.exitButton = gtk.ToolButton("gtk-quit")
++ self.exitButton.set_tooltip_text(_("Exit DRIconf"))
++ self.exitButton.connect("clicked", self.exitHandler)
++ self.exitButton.show()
++ self.toolbar.insert(self.exitButton, -1)
+ if len(configList) != 0:
+ self.activateConfigButtons (configList[0])
+ self.toolbar.show()
diff --git a/x11-misc/driconf/metadata.xml b/x11-misc/driconf/metadata.xml
new file mode 100644
index 000000000000..6cc3982431f8
--- /dev/null
+++ b/x11-misc/driconf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>x11</herd>
+</pkgmetadata>