summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-25 06:41:14 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-25 06:41:14 +0200
commit25ed9373c778f825187a4df9a775bf243e291a50 (patch)
tree640c6dc4d3716765797692e7dc532e232d973020 /x11-misc/dunst
parentnet-dns/libidn2: Version bump. (diff)
downloadgentoo-25ed9373c778f825187a4df9a775bf243e291a50.tar.gz
gentoo-25ed9373c778f825187a4df9a775bf243e291a50.tar.bz2
gentoo-25ed9373c778f825187a4df9a775bf243e291a50.zip
x11-misc/dunst: Version bump (bug #625250).
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'x11-misc/dunst')
-rw-r--r--x11-misc/dunst/Manifest1
-rw-r--r--x11-misc/dunst/dunst-1.2.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index 182bd8b49371..032e543e391e 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1 +1,2 @@
DIST dunst-1.1.0.tar.bz2 79032 SHA256 c72bf167eaab4e44a98ec87101b023efee0aa8916df56630b99a5bc53f8d7070 SHA512 ba01a6b18da5199b3356342f5c22592f93f447389267810bbfc35decf1a67f89650d445d3c1dd6f3cc76a4f86f7165adc777b669444627e42d3e671d4f04a04b WHIRLPOOL 6985c17549de4c7f6e2ba17ae1117db21693f4ed05df65e6238cfe6001aeb9c7a98834f3e794a0c80dbe913099082624256708c29ffa02cf35b0ab0032e94926
+DIST dunst-1.2.0.tar.gz 110628 SHA256 a3c05b5ef87e88704a6207236e42773dfbcf50cb23c7cf51e494a7236b75c5ad SHA512 223c8aae61574770a76bff84723643a3c03d3d9a8f4094bc4e92e16826703e7c0a7c3327945db8469b8dcc48fe5cfaba51e6724149e6571a7ffc1716656e30f3 WHIRLPOOL 1c9cac734d8d5378a7fe77381847a94db692b59d26bbaa6e06d9a65d168c371a2fd2ce4a649b9ded130c4228940bfe01004c38eb20889e8794e25a83e7ba46df
diff --git a/x11-misc/dunst/dunst-1.2.0.ebuild b/x11-misc/dunst/dunst-1.2.0.ebuild
new file mode 100644
index 000000000000..a7e10556b679
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="customizable and lightweight notification-daemon"
+HOMEPAGE="http://www.knopwob.org/dunst/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dunstify"
+
+CDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxdg-basedir
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/libXScrnSaver
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/pango[X]
+ dunstify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ default
+
+ # Remove nasty CFLAGS which override user choice
+ sed -i -e "/^CFLAGS/ { s:-g::;s:-O.:: }" config.mk || die
+
+ if use dunstify; then
+ # add dunstify to the all target
+ sed -i -e "/^all:/ s:$: dunstify:" Makefile || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ if use dunstify; then
+ dobin dunstify
+ fi
+
+ dodoc AUTHORS CHANGELOG.md RELEASE_NOTES
+}