summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-06-03 12:25:53 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 15:32:59 +0300
commitc212bd5f4c7c04f802d025be24968f3d434b6c97 (patch)
treed920d4ab5ea1878c83e61ffa8f20a53f635ad79d /x11-misc/fbpager
parentx11-misc/fbpager: Set C++ standard to 14. (diff)
downloadgentoo-c212bd5f4c7c04f802d025be24968f3d434b6c97.tar.gz
gentoo-c212bd5f4c7c04f802d025be24968f3d434b6c97.tar.bz2
gentoo-c212bd5f4c7c04f802d025be24968f3d434b6c97.zip
x11-misc/fbpager: EAPI bump, revbump.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/20809 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/fbpager')
-rw-r--r--x11-misc/fbpager/fbpager-20090221-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/fbpager/fbpager-20090221-r2.ebuild b/x11-misc/fbpager/fbpager-20090221-r2.ebuild
new file mode 100644
index 000000000000..6980614a4620
--- /dev/null
+++ b/x11-misc/fbpager/fbpager-20090221-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A Pager for fluxbox"
+HOMEPAGE="http://git.fluxbox.org/fbpager.git/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="+xrender"
+
+DEPEND="x11-libs/libX11
+ xrender? ( x11-libs/libXrender )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ append-cxxflags "-std=c++14"
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable xrender)
+}
+
+pkg_postinst() {
+ einfo "To run fbpager inside the FluxBox slit, use fbpager -w"
+}